4.20a1JP

4.X系の開発

モデレータ: 暇人, YoN, nyu

4.20a1JP

投稿記事by シノバー » 09/06/04(木) 19:45

次のところに isoファイルを置きました。
http://122.102.213.192/video/public/puppy/
  • (通常カ−ネル) ....... puppy-420a1-JP.iso
  • (レトロカ−ネル) ... puppy-420a1-retro-JP.iso
4.20JP, 4.20retroJPからの修正点は以下のとおりです。
  1. initrd.gz内のinit - 実装RAM256MB未満で起動しなくなる不具合の解消
  2. pupsave - 2桁のパ−ティション番号を持つ場合に保存ファイルが作れない不具合の解消
  3. pmount - iso9660 および etx2/ext3 のマウントに失敗する不具合の解消
  4. /usr/lib/libttf.so.3 を /usr/lib/libtiff.so.5 にもコピ− - Xsane関連(後述)
  5. /usr/lib/syslinux/files/boot.msg - バ−ジョン番号
  6. remax - これ、ぜんぜん動かないやん。ということで手直し。

Xsaneはgimpを入れないと動きません。Gimp不要の修正パッケ−ジがありますが、上のものには入れてません。
関連トピック http://sakurapup.browserloadofcoolness. ... php?t=1063

remaxは今回isoファイルを作るのに便利そうだったので手直しして使いました。
でも、まだまだバグ含みかと。

その他の関連トピック
http://sakurapup.browserloadofcoolness. ... php?t=1117
http://sakurapup.browserloadofcoolness. ... php?t=1099
http://sakurapup.browserloadofcoolness. ... php?t=1074

で、今後の予定ですが、上記のほかにどうしても入れたい修正があれば
今週末までに提案ください。組み込むべきものがあれば組み込み、
週明けはテストに充てたいと思います。

修正版の正式リリ−スは来週中ということでいかがでしょうか。
また、修正版の名前はどうしましょ。 4.20a?JP 4.20a?retroJP でいいですか?
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Re: 4.20a1JP

投稿記事by » 09/06/05(金) 00:23

いくつかあるうちで1つ修正可能なら、ぜひともお願いしていただきたいのがあります。

起動時に無線LANの設定済IPに接続できたり失敗したりという場合があります。
無線ルータまでの距離が約3mで無理な距離ではありません。
接続失敗後、無線スキャナ(Pwireless)を起動するとリストには接続先が無く、再探査で発見後サクッと接続できます。
プログラム的なバグなのか特定使用機器(PCMCIA : PLANEX GW-NS54CW)の問題なのかもしれませんが、
毎日使ってる感じだとIP探査時間が短くて接続先が見つけられずタイムアウトで接続失敗な感じがしないでもないです。

修正可能なようでしたら是非ともよろしくお願いいたします。

[pup-424ja/default] Fujitsu FMV-830NU/L (1.5GHz/Mem:768MB)
[Puppy4.2p1-JP/2nd] NEC VY10M BW-W (1.0GHz/Mem:1.2GB)
[pup-424ja/1st] 自作機(Core 2 Duo E4300 1.8GHz/Mem:3GB)
無線LAN : PLANEX GW-NS54CW
アバター
 
記事: 78
登録日時: 09/05/27(水) 19:41
お住まい: 大阪府

投稿記事by YoN » 09/06/05(金) 07:18

シノバーさん、ありがとうございます。
今後の予定ですが、上記のほかにどうしても入れたい修正があれば
今週末までに提案ください。組み込むべきものがあれば組み込み、
週明けはテストに充てたいと思います。

修正版の正式リリ−スは来週中ということでいかがでしょうか。
また、修正版の名前はどうしましょ。 4.20a?JP 4.20a?retroJP でいいですか?

結構です。よろしくお願いします。
「バグ、トラブル」のmetaboさんのドライブアイコンが重なる事も検証できましたらお願いします。
[Puppy4.1.2-retro-JP] EPSON Endeavor MT-3500
Celeron 533MHz 256MB
[Lupu-5.0.1 LiveCD + lang_support_ja-1.4.sfs] SOTEC Whitney System CR Board
Celeron 766MHz 512MB
アバター
YoN
Site Admin
 
記事: 1239
登録日時: 07/04/01(日) 08:00
お住まい: 信州

Re: 4.20a1JP

投稿記事by シノバー » 09/06/05(金) 09:22

玉 さんが書きました:起動時に無線LANの設定済IPに接続できたり失敗したりという場合があります。

これは私も感じてまして、みなさんもいろいろ対処療法をされているかと思います。

ですが、誤解を呼んですみません。ここで期待しているのは..
本家公式4.21ほかフォ−ラムなどで修正パッケ−ジが公開されているが
4.20JPには採り入れられていないものなど、
どこを直せば良いかすでに分かっているものです。

よろしくお願いします。
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Re: 4.20a1JP

投稿記事by » 09/06/05(金) 14:26

先の件、了解いたしました。

折を見て4.20a1-JP検証してみますね。

[pup-424ja/default] Fujitsu FMV-830NU/L (1.5GHz/Mem:768MB)
[Puppy4.2p1-JP/2nd] NEC VY10M BW-W (1.0GHz/Mem:1.2GB)
[pup-424ja/1st] 自作機(Core 2 Duo E4300 1.8GHz/Mem:3GB)
無線LAN : PLANEX GW-NS54CW
アバター
 
記事: 78
登録日時: 09/05/27(水) 19:41
お住まい: 大阪府

Re: 4.20a1JP

投稿記事by » 09/06/05(金) 19:16

[検証機]
Fujitsu FMV-830NU/L (Celeron-M 1.5GHz, Mem:768MB) [Puppy4.2a1-JP]
新規HDD : Fujitsu 40GB (ATA、ファイルなし)
従来HDD : Hitachi 80GB (ATA、pup_420jp.sfs入り)

4.20a1JPできるとこまで検証してみました。
おおざっぱ検証で申し訳ないです。

1. initrd.gz内のinit - 実装RAM256MB未満で起動しなくなる不具合の解消
  ●手持ち最小メモリが256MBなのでRAM256MB未満は未検証。
   256MBでのテストではエラーは無し。
 http://sakurapup.browserloadofcoolness.com/viewtopic.php?t=1117

2. pupsave - 2桁のパ−ティション番号を持つ場合に保存ファイルが作れない不具合の解消
  ●空きHDD40GBがあるので、とりあえずWindowsXP@NTFSで3GB少々@12ケ切ってみる。
   新規HDDが11ドライブしか認識しないけどpup_save-42a1test.2fs、pup_420a1JP.sfsの保存は確認。

   従来の2パ−ティションHDDでpup_420jpがある場合
    poweroff時に保存にはとりあえず進んでるフリはしてますが保存ファイルは存在しない。
    再起動では毎回わざわざCD-ROMのpup_420a1jp.sfsを読み、終了時に破棄みたい。

3. pmount - iso9660 および etx2/ext3 のマウントに失敗する不具合の解消
  ●2パターンで検証。
   12パ−ティションの新規の場合
    etx2/ext3 のマウント成功確認。Pmountでも光学ドライブマウント問題無し。

   従来のHDDでpup_420jpがある場合
    4.20a1JP版でもデスクトップ上sr0はマウントできますがPmountでは光学ドライブはマウント失敗。
    fd0はFD生ディスクが無い場所なのでパス。

4. /usr/lib/libttf.so.3 を /usr/lib/libtiff.so.5 にもコピ− - Xsane関連(後述)
  ●確認。

5. /usr/lib/syslinux/files/boot.msg - バ−ジョン番号
  ●確認。

6. remax - これ、ぜんぜん動かないやん。ということで手直し。
  ●CD-RW生ディスクの空きが無いので未検証。

[pup-424ja/default] Fujitsu FMV-830NU/L (1.5GHz/Mem:768MB)
[Puppy4.2p1-JP/2nd] NEC VY10M BW-W (1.0GHz/Mem:1.2GB)
[pup-424ja/1st] 自作機(Core 2 Duo E4300 1.8GHz/Mem:3GB)
無線LAN : PLANEX GW-NS54CW
アバター
 
記事: 78
登録日時: 09/05/27(水) 19:41
お住まい: 大阪府

Re: 4.20a1JP

投稿記事by シノバー » 09/06/07(日) 08:02

おはようございます。

今回の修正の提案は本日中で締切り、追加がなければさきの
420a1JPで月曜から本格的テストに入り、今週末リリ-スでよろしいですか?

玉 さんが書きました:12ケ切ってみる。 新規HDDが11ドライブしか認識しない

これ、ときどきありますね。
とくにUSBドライブ、またとくにretroカーネルで多いので、カーネルがらみなのかな。
残念ながら今回には間に合わないと思います。

特定解像度でドライブアイコンが重なる問題
http://sakurapup.browserloadofcoolness. ... php?t=1123
本日中に報告が無ければ需要は少ないということで、今回は修正なしとします。
該当ハードでの報告をお待ちします。 eeePCでも検証お願いします。
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

メモリ128MBの確認

投稿記事by ぴて » 09/06/07(日) 20:49

メモリを一本外してメモリ128MBにし、4.20a1retroJPの動作確認しました。

4.20a1retroJP:Flugalインストールにて問題なく起動
4.20retroJP:起動時kernel panic
4.1.2.1retroJP:問題無し

動作には問題ないかと思います。
ぴて
Puppy 4.1.2.1retroJP and 4.20p1retroJP
K6-2 450MHz 256MB 20GB
ぴて
 
記事: 10
登録日時: 08/11/23(日) 15:26
お住まい: 長野県

Re: 4.20a1JP

投稿記事by 暇人 » 09/06/25(木) 04:09

jwmでflashがフルスクリーンにならないのが改善されてますね。
gettext化されるともっと良いんだけどなぁ。
管理人見習い
NEC Express5800 S70/SR G6950 2.8GHz/1G
lenovo S10-3 AtomN450 1.66G/1G
暇人/貳馬力/2CV
アバター
暇人
 
記事: 2388
登録日時: 07/08/12(日) 23:33
お住まい: 埼玉県xx市並4


Return to 4.X系

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]

cron