571JP レポート

5.X系のバグ、トラブル・質問

モデレータ: 暇人, YoN, nyu

571JP レポート

投稿記事by 暇人 » 14/01/18(土) 16:10

新しくリリースされたPrecise-571JP のレポートはこちらに。

問題があることが分かっているだけでも次回の開発に役立ちます。
お気軽にレポートをお願いいたします。

ただし必ず解決するとは限りません。
環境(機種、CPU等)状況を詳しく添えると解決に役立ちます。
最後に編集したユーザー 暇人 [ 14/01/19(日) 14:01 ], 累計 1 回
アバター
暇人
 
記事: 2386
登録日時: 07/08/12(日) 23:33
お住まい: 埼玉県xx市並4

Re: 571JP レポート

投稿記事by Endeavor_wako » 14/01/18(土) 20:26

571JPのISOをCD-RWへ焼こうとしたら、右クリックで呼び出される Burn with Pburnで焼けませんでした。途中で動作していないっぽいです。但し、CD-RWの消去はできました。そしてBurniso2cd が動いたので実用上問題はないのですが。
ハード Thinkpad R500 光学ドライブはHL-DT-ST DVDRAM GSA-T50N (LG Electronics) - Hardinfo による -
Main:lenovo ThinkPad R500,LinuxMint17.2Xfce(x64)
Sub:ASUS eeePC 1001PX,Slitaz rolling, LM17.2Xfce(x86)に変えました
Old sub:Matsushita CF-R2,Slitaz rolling

Puppyを使わなくなって久しい今日この頃。引き続き、会話シュミレーターは無視する方向で。
Endeavor_wako
 
記事: 378
登録日時: 09/09/18(金) 01:54

Re: 571JP レポート

投稿記事by ふうせん Fu-sen. » 14/01/18(土) 20:57

何台か 571JP をインストールしていました。

Eee PC 4G ではじめて起動した際に CLI で止まりました。解像度 800×480 の影響ですね。
xorgwizard の起動メッセージが出ているので、そのとおりに xorgwizard を起動し、
これよりも大きい解像度を選んだところ、無事に 800×480 で認識し、
その後 xwin で GUI で扱え、再起動後はその解像度で使えています。
ただ、CLI は 640×480 表示になっています。lupu-528JP は CLI も 800×480 表示でした。

従来と動きが変わってるのと、CLI 表示で止まるので、
もしかするとその辺をトラブル報告されるケースがありそうな気がするので残しておきます。
ネットブック等の特別な解像度のパターンです。
ふうせん Fu-sen. ( old: 2 8 6 )
ふうせん Fu-sen.
 
記事: 561
登録日時: 13/09/17(火) 10:01

Re: 571JP レポート

投稿記事by Endeavor_wako » 14/01/18(土) 21:17

いまさら感120%で申し訳ありません。日頃はISOをマウントして内容物を抜き取る手動インストールばかりやっているので。

作成したCD-RWを使ってPCへのFrugal インストールしていて気づいたこと。
Frugal Installer v.1.5 にて、デフォルトのフォルダ名がprecise です。ここはやはり PuppyLinux571JPのほうがよろしいのではないかと。ubuntu precise 派生のPuppyって他にもありますので。
Main:lenovo ThinkPad R500,LinuxMint17.2Xfce(x64)
Sub:ASUS eeePC 1001PX,Slitaz rolling, LM17.2Xfce(x86)に変えました
Old sub:Matsushita CF-R2,Slitaz rolling

Puppyを使わなくなって久しい今日この頃。引き続き、会話シュミレーターは無視する方向で。
Endeavor_wako
 
記事: 378
登録日時: 09/09/18(金) 01:54

Re: 571JP レポート

投稿記事by ふうせん Fu-sen. » 14/01/18(土) 21:25

Endeavor_wako さんが書きました:作成したCD-RWを使ってPCへのFrugal インストールしていて気づいたこと。
Frugal Installer v.1.5 にて、デフォルトのフォルダ名がprecise です。ここはやはり PuppyLinux571JPのほうがよろしいのではないかと。ubuntu precise 派生のPuppyって他にもありますので。

すでに precise がある時は puppy で生成を試みて、それもある時は〜という動作ですね。
例えば 550JP も precise で生成するので、
550JP が入っている時に 571JP を入れる場合はこのようになります。
おそらくオリジナルから変更していない動作でしょう。

これでインストールしてしまっても、フォルダ名変更して GRUB の記載を変える事はできるので、
困った状態にはならないですね。
行わないで、どっちのフォルダがどっちのバージョン???は初心者にはあるかもしれません。
ふうせん Fu-sen. ( old: 2 8 6 )
ふうせん Fu-sen.
 
記事: 561
登録日時: 13/09/17(火) 10:01

右下の通知領域に表示される、Opera ボタンの背景

投稿記事by cygnus_odile » 14/01/19(日) 06:30

右下の通知領域に表示される、Opera ボタンの背景ですが、

      ↓ (Puppy Linux 431JP2012)
画像
          ↑ (Precise 571JP)

で、オペラボタンだけ、背景が白いのは、見栄えが悪いので、
オペラボタンの背景が透明というか、背景がまわりのトレイ(ぱねる)と同色にできないでしょうか?
(puppy というより、Opera の問題かもしれませんが)
cygnus_odile
 
記事: 665
登録日時: 09/08/16(日) 14:30

Re: 571JP レポート

投稿記事by cygnus_odile » 14/01/19(日) 23:31

私が使用中のパソコンはやや非力なので、
precise-571JP では、Opera-Browser の初回起動に、
  約9.5秒掛かります。
一方、オリジナル英語版ですと、Opera-Browser の初回起動は、
  約5.8秒程度です。

これは、メインsfs の圧縮様式の違い(JPは、xz, 英語オリジナルは gzip )に起因するものと推察し、
  puppy_precise_5.7.1JP.sfs
を、gz 圧縮し直したところ、赤字で
  puppy_precise_5.7.1JP.sfs not found

と警告され、起動しません。そういうものなのでしょうか? それとも、mksqaushfs に失敗してるのでしょうか?
  gzip 圧縮してみたもの、
  161157120 14-01-19 17:21 puppy_precise_5.7.1JP.sfs (153.7MB)
  0df77ca25c9c986fbbf0c35a89bd9105 (md5)
最後に編集したユーザー cygnus_odile [ 14/01/25(土) 10:40 ], 累計 1 回
cygnus_odile
 
記事: 665
登録日時: 09/08/16(日) 14:30

既知の問題

投稿記事by シノバー » 14/01/22(水) 09:03

1.「軽い暗号化」ではセッションを保存できません。代わりに「重い暗号化」を利用ください。 viewtopic.php?f=12&t=2478
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Re: 571JP レポート

投稿記事by Endeavor_wako » 14/01/23(木) 13:42

Glade のダウングレード

devx を追加すると、GTK+ のインターフェースデザイナである Gladeがメニューのユーティリティに現れます。

が、起動しません。
これはgtk3関連のライブラリがPuppyでは未整備なままだからです。試しに端末からgladeと入力すると、
# glade
glade: error while loading shared libraries: libgtk-3.so.0: cannot open shared object file: No such file or directory
と表示されます。

安易な対策:
リポから glade-gtk2_3.8.0 を関連ライブラリも含めてインストール。
/usr/share/applications にある、glade.desktop を削除するか拡張子を変更して無効化。
メニューより、 デスクトップ -> デスクトップの修復を実行。

僕はgtk+2系で不自由しないので。gtk+3へ移行しようとする人は素直にlibgtk-3をインストールすべきでしょうね。


余談ですがdevxって意外に未整備のような気がします。571JP本体からは外された(代わりにoperaが採用された)seamonkey関係のライブラリが含まれていたりします。これを削除すると少しは小さくなりますから、ついでにglade-3.8.0 を含めてしまうのも良いでしょう。(手順:マウントして中身を他所へ完全コピー、不要なファイルを削除&必要なものを追加、再度sfsに固める。作業には相当のディスク容量を要します...)
Main:lenovo ThinkPad R500,LinuxMint17.2Xfce(x64)
Sub:ASUS eeePC 1001PX,Slitaz rolling, LM17.2Xfce(x86)に変えました
Old sub:Matsushita CF-R2,Slitaz rolling

Puppyを使わなくなって久しい今日この頃。引き続き、会話シュミレーターは無視する方向で。
Endeavor_wako
 
記事: 378
登録日時: 09/09/18(金) 01:54

Re: 571JP レポート

投稿記事by Endeavor_wako » 14/01/24(金) 00:26

571JPに原因がある訳ではありませんが、アプリケーションとして収録されているので。

pupRadio で NHK を聞こうとすると私の環境ではすぐに音が出なくなります。アドレスをGNOME-MPlayerに直接渡してみても同じ。切断されているのかしらん。

以前コマンドラインから らじるらじる や radiko を聞く方法が紹介されていたことを思い出し、そちらを実行してみました。
viewtopic.php?f=30&t=2317

暇人さん作成のpetでは /usr/local/以下に展開されるようになっていましたので、/usr 以下へ引越し。ついでにswfextractも /usr/bin に移動。シェルスクリプトは後から弄れるように /root/my-applications/bin へ移動しました。
同梱されているplay_radiko.shを実行しようとすると xmllint が見つからない、といってエラーになりますが、これはdevxに含まれています。devxを使いたくない場合はリポからxml2-utilsをインストールしてください。(検索すると既にインストール済み、と表示されますが無視しましょう。)

この方法でも運が悪いと引っかかってなかなか音が出なかったりしますが、mms:で聞くよりは余程安定して受信できます。

ところで。
ちょっと気になってチェックしてみたのですがサーチパスの順序ってこれでいいんでしょうか?

# set | grep "PATH"
LD_LIBRARY_PATH=/lib:/usr/lib:/usr/X11R7/lib:/root/my-applications/lib:/usr/local/lib
MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins
PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/bin:/usr/X11R7/bin:/root/my-applications/bin:/usr/games
PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/lib/seamonkey-devel-2.19/sdk/lib/pkgconfig:
WINDOWPATH=4
※devxをマウントしています。

autotools系の configure では --prefix= でインストール先を指定できます。今、--prefix=/root/my-applications とした場合、実行ファイルは /root/my-applications/bin へ、ライブラリは /root/my-applications/lib へインストールされます。
でもPuppyのサーチパスだと、/root/my-applications/libは前から4番目で /usr/local/bin の前、/root/my-applications/binは7番目で/usr/local/binの2つ後です。
/usr/local (configureでのデフォルト)に入れたものを消さずに、改変したものを/root/my-applications へ入れ直した場合、辻褄があわなくなりそうです。
まあ、そもそも一つの環境で同じパッケージを節操なくあちこちインストールすることは慎むのが当然。私は時々やらかして一人で焦ってますが。

気になるならサーチパスを修正すれば良いのでしょうが、下手に弄って(typoして)今度はシステムが所定のファイルを見つけられない、なんてことになっても嫌なのでそのままです。また、こうなっているのは何か理由があるのでしょう。
Main:lenovo ThinkPad R500,LinuxMint17.2Xfce(x64)
Sub:ASUS eeePC 1001PX,Slitaz rolling, LM17.2Xfce(x86)に変えました
Old sub:Matsushita CF-R2,Slitaz rolling

Puppyを使わなくなって久しい今日この頃。引き続き、会話シュミレーターは無視する方向で。
Endeavor_wako
 
記事: 378
登録日時: 09/09/18(金) 01:54

Re: 571JPの改造

投稿記事by シノバー » 14/01/25(土) 09:42

cygnus_odile さんが書きました:  puppy_precise_5.7.1JP.sfs
を、gz 圧縮し直したところ、赤字で
  puppy_precise_5.7.1JP.sfs not found

と警告され、起動しません。そういうものなのでしょうか?

たぶん、そういうものなのでしょう。
パピーは最低3つのファイルから起動します。Vmlinuz → initrd.gz → パピーSFS
このうち vmlinuz と パピーSFSには隠しIDが付けられています。このIDが無いと、いろいろ不具合が起こります。
Remaster2 や Remasterx でリマスタすると適切なIDが付けられます。
リマスタによらない場合、mkdistなどをご使用ください。
viewtopic.php?f=30&t=2436
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Re: 571JP レポート

投稿記事by ふうせん Fu-sen. » 14/01/25(土) 10:32

自分もちょうどその辺を行ってましたので……

簡単なのは、リマスターで puppy_precise_5.7.1JP.sfs を生成した場合、
合わせて生成された initrd.gz vmlinuz は一緒にコピーしておくと良いです。
これで起動するようになります。

変化していないようで、変化してるんです。
puppy_precise_5.7.1JP.sfs だけのコピーでは起動しなかったんです…… :x
ふうせん Fu-sen. ( old: 2 8 6 )
ふうせん Fu-sen.
 
記事: 561
登録日時: 13/09/17(火) 10:01

idstring

投稿記事by シノバー » 14/01/25(土) 11:04

隠し ID string についての解説が少し
viewtopic.php?f=27&t=2129&p=15731#p15731
この ID string は 528 の時代には 16文字でしたが、現在は32文字。
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Re: 571JP レポート

投稿記事by 486HA » 14/01/25(土) 18:41

cygnus_odile さんが書きました:  puppy_precise_5.7.1JP.sfs
を、gz 圧縮し直したところ、赤字で
  puppy_precise_5.7.1JP.sfs not found

と警告され、起動しません。そういうものなのでしょうか? それとも、mksqaushfs に失敗してるのでしょうか?

Retro のオリジナル版はgz圧縮でしたが、インストールされているremasterpup2 自体が
01micko さんによってxz圧縮に変更されているのでリマスターするとxz圧縮になってしまいます。
 puppy_precise_5.7.1JP.sfs だけをgz圧縮に変更しても、レポートのような結果になります。
正常に起動できるようにするにはinitrd.gzも編集して再構築する必要があります。
以下は、その方法です。
1、Precise 5.7.1JP をRAMモードで起動します。
2、initird.gzを/root にコピーします。
3、Edit-Initrdgz-1.4_ja.sfsをロードして起動します。
https://docs.google.com/file/d/0BxoqlpBAJsQIZFpwMTZZYTBKc0k/edit

4、INITRD.GZを開いてDISTRO_SPECSを二つとも同じように修正します。
次の二つの行の'JP'を削除します。
  5行目:DISTRO_SURFFIX='JP'
27行目:DISTRO_PUPPYSFS='puppy_precise_5.7.1JP.sfs'
5、INITRD.GZを再構築を実行したら、/root にあるinitird.gzをオリジナル版に上書きします。
6、puppy_precise_5.7.1JP.sfsを、puppy_precise_5.7.1.sfsにリネームします。
7、再起動して、puppy_precise_5.7.1.sfsが読み込まれて起動することを確認します。
8、起動したらsfs_pet_util_5.7.1.sfsをロードして、puppy_precise_5.7.1.sfsを右クリックしてEdit-SFSを起動します。
[url]]https://docs.google.com/file/d/0BxoqlpBAJsQINWh5bnBoOFJub2M/edit[/url

9、puppy_precise_5.7.1.sfsが展開されたら、その中の/etc/DISTRO_SPECSを開いて、
 4と同じように編集したら、GZを選択してpuppy_precise_5.7.1.sfsを再構成します。

 以上の作業で、gz圧縮されたpuppy_precise_5.7.1.sfsが読み込まれ起動できるようになります。
パーミッションが与えられていないため、記事の添付ファイルを見ることができません
CORE-i7-6700HQ uEFI ram:8GB
Full: Quirky Xerus-64 8.2
save2dir: Tahr 6.0.6(32/64), Slacko 6.9.9(32/64),Xenialpup 7.0.8.1
Slimjet 15.0.3.0(32/64)
486HA
 
記事: 1142
登録日時: 11/03/06(日) 14:31

Re: 571JP レポート

投稿記事by cygnus_odile » 14/01/25(土) 19:30

シノバーさん、ご教示&解説ありがとうございます。
486HA さん、詳しい手順の説明ありがとうございます。

(とりあえず、真面目にリマスターしないまま、vmlinuz から読み取ったIDを、/etc/DISTRO_SPEC 記載のものと同一であるのを確認し、 gzip しなおした pup本体sfsファイル に強引にIDを付加してとりあえずの起動に成功してます・・・ズルですけど・・・。Opera-Browser の初回起動は、約10秒掛かっていたのが 6秒半程度に短縮しました。 CPU がひ弱なものですから、xzで圧縮された物を展開するオーバーヘッドもバカにならないみたいでして。)
cygnus_odile
 
記事: 665
登録日時: 09/08/16(日) 14:30

次へ

Return to 5.X系

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]