LuPu5.1.0のかな入力で,「む」が打てない件。

以上のフォーラム以外のトラブル

モデレータ: 暇人, YoN, nyu

LuPu5.1.0のかな入力で,「む」が打てない件。

投稿記事by o6asan » 10/08/19(木) 00:36

表題どおりです。
じかに,jp106.gzを直そうとしたのですができなかったので,次善の策として以下の方法で解決しました。

runlevel3は問題ないので,x上の話です。

端末から,xevで調べてみると,
keycode 51 (keysym 0x5d, bracketright) であるべきものが,
keycode 51 (keysym 0x5c, backslash) になっていました。

~/.Xmodmapをつくって,中に
keycode 51 = bracketright braceright
を記入。これで,.xinitrc が読んでくれます。
アバター
o6asan
 
記事: 7
登録日時: 10/05/22(土) 02:30

Re: LuPu5.1.0のかな入力で,「む」が打てない件。

投稿記事by シノバー » 10/08/19(木) 06:35

o6asanの方法も解の一つですが、一般にパピーでは「マウス/キーボードウィザード」から「Xの高度な設定」でキーボードモデルを jp106 に設定してやれば治ります。あるいは /etc/X11/xorg.conf をじかに編集してやるか。

しかし LuPu5.1.0でこれをやろうとすると、xorg.conf にキーボードのエントリがありませんから、まずは xorgwizardを動かし……と、ちょっと大変です。
この問題に対しては Lucid Puppy QuickSet を開発中で現在はアルファステージです。できればご協力ください。
viewtopic.php?t=1860
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Re: LuPu5.1.0のかな入力で,「む」が打てない件。

投稿記事by o6asan » 10/08/19(木) 14:33

シノバーさん,お返事ありがとうございました。

投稿の前に,かなり検索してみたつもりだったんですが,キーワードが悪くてあたらなかったようです。
「Re: 日本語化されたpupletsではないけれど puppeee 他」という表題で同じ項目を扱っているものが,「xの高度な設定」という
キーワードで,見つかりました。先に,発見していれば,良かったんですが。

また,シノバーさんのおっしゃるとおり,「xの高度な設定」でjp106キーボードにすることで,当該不良は良くなりました。

ただ,
Option "XkbModel" "jp106"
Option "XkbLayout" "jp" #xkeymap0
は終わっていたのですが,その時点で,「む」については改善されていませんでした。

ところで,下記について
> この問題に対しては Lucid Puppy QuickSet を開発中で現在はアルファステージです。できればご協力ください。
> viewtopic.php?t=1860
リンク先を読んでもピンとこないのですが,協力というのはどのようなことをするのでしょうか。
アバター
o6asan
 
記事: 7
登録日時: 10/05/22(土) 02:30

Re: LuPu5.1.0のかな入力で,「む」が打てない件。

投稿記事by シノバー » 10/08/19(木) 20:52

o6asan さんが書きました:> この問題に対しては Lucid Puppy QuickSet を開発中で現在はアルファステージです。できればご協力ください。
> viewtopic.php?t=1860
リンク先を読んでもピンとこないのですが,協力というのはどのようなことをするのでしょうか。

試用して動作・不具合の報告をしていただくというのは、たいへん助けになります。あるいは要望や提案をするのも。
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05


Return to その他

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]