Flashサイトでブラウザが落ちるので、Flashblockをインストールしました

リリースされた日本語版に関するバグ、トラブル

モデレータ: 暇人, YoN, nyu

Re: Flashサイトでブラウザが落ちるので、Flashblockをインストールしました

投稿記事by みのむし » 10/01/23(土) 13:21

私の環境)
 ハードは省略します。
ソフトのみ示します。

Puppy 4.3.1JP
 pup-431JP.sfs
 zp431305.sfs
 devx_431.sfs
 Firefox 3.5.7
  firefox-3.5.3-430-i486
   私が独自にPETパッケージを作成したもの。
    元は4.1.2.1-JPに入っていた firefox + 必要なライブラリ(dbus-libs、dbus-glib PETパッケージ)
    URL: http://www.mland.jp/pub/Linux/Puppy/use ... o/firefox/
    firefox-3.5.3-430-i486.pet
    URL: http://www.mland.jp/pub/Linux/Puppy/users/msato/Libs/
    dbus-libs-1.1.2-12.el5.i386.pet
    dbus-glib-0.73-8.el5.i386.pet
コード: 全て選択
# cd /lib
# ls -l libdbus*
lrwxrwxrwx 1 root root     18 2009-12-23 20:16 libdbus-1.so.3 -> libdbus-1.so.3.4.0
-rwxr-xr-x 1 root root 251880 2009-01-21 18:45 libdbus-1.so.3.4.0
# cd /usr/lib
lrwxrwxrwx 1 root root     23 2009-12-23 20:16 libdbus-glib-1.so.2 -> libdbus-glib-1.so.2.1.0
-rwxr-xr-x 1 root root 118336 2009-01-21 16:49 libdbus-glib-1.so.2.1.0

 Flash Player 10.0 r42
  これはPETパッケージをインストールしました。
 ※現在、個人保存ファイルの残りサイズは 358M です。
コード: 全て選択
# cd /usr/lib/mozilla/plugins
# ls -l
-rwxr-xr-x 1 root root     1073 2007-12-11 09:13 gxineplugin.la
-rwxr-xr-x 1 root root    14572 2009-09-16 22:59 gxineplugin.so
-rwxr-xr-x 1 ftp  ftp  10248260 2009-10-28 12:26 libflashplayer.so
lrwxrwxrwx 1 root root       62 2009-10-04 16:18 libjavaplugin_oji.so -> ../../../java/jre1.6.0_16/plugin/i386/ns7/libjavaplugin_oji.so
-rw-r--r-- 1 root root    41200 2009-06-12 01:48 libmozsvgdec.a
-rwxr-xr-x 1 root root      914 2009-06-12 01:48 libmozsvgdec.la
-rwxr-xr-x 1 root root     7276 2009-09-16 22:59 libmozsvgdec.so
-rwxr-xr-x 1 root root   249624 2007-10-19 11:39 mplayerplug-in-dvx.so
-rwxr-xr-x 1 root root     1021 2007-10-19 01:05 mplayerplug-in-dvx.xpt
-rwxr-xr-x 1 root root   249848 2007-10-19 11:39 mplayerplug-in-qt.so
-rwxr-xr-x 1 root root     1021 2007-10-19 01:05 mplayerplug-in-qt.xpt
-rwxr-xr-x 1 root root   249864 2007-10-19 11:39 mplayerplug-in-rm.so
-rwxr-xr-x 1 root root     1021 2007-10-19 01:05 mplayerplug-in-rm.xpt
-rwxr-xr-x 1 root root   250200 2007-10-19 11:39 mplayerplug-in-wmp.so
-rwxr-xr-x 1 root root     1021 2007-10-19 01:05 mplayerplug-in-wmp.xpt
-rwxr-xr-x 1 root root   251168 2007-10-19 11:39 mplayerplug-in.so
-rwxr-xr-x 1 root root     1021 2007-10-19 01:05 mplayerplug-in.xpt
-rwxr-xr-x 1 root root   127260 2010-01-23 14:00 nppdf.so

 gxine のプラグイン
 Flash のプラグイン
 Java のプラグイン
 Mozilla のプラグイン
 MPlayer のプラグイン
 PDF のプラグイン

http://flightbookings.airnewzealand.co. ... iew/en_NZ/

http://www.asahi.com/
 このページは画像が滅多やたらに多く、また、Fash も表示されています。
 メモリを大量(358M でも少ないかも)に消費するのでは?
 何か操作すると、すぐに落ちますが、Firefoxのバグとは違うような...
 このページを見るための対策)
  対策になるかどうか...
  落ちやすいのは変わりません。
  ・個人保存ファイルのリサイズを行って、残りサイズを出来るだけ大きくする。
  ・Puppy を再起動して、すぐにFirefox を起動してこのページを開く。
   他のアプリは停止しておく。
   1個のタブ、多数のタブを開かない。

Firefox パッケージの依存性チェック
 firefox パッケージにライブラリの不足が無いかチェックする。
 メニュー|セットアップ|パッケージの依存性チェック
 (ウィンドウがデスクトップ画面からはみ出るので、[Alt]キーを押しながらドラッグして、Firefoxパッケージにチェックし、[依存性チェック]ボタンをクリック)
 私の環境でもこれでチェックすると、以下のライブラリが不足していると出ますが、起動出来ています。
  libxui.so
  libgnomevfs-2.so.0
  libgconf-2.2o.4
  libORBit-2.so.0
  libgio ← プログラムのバグ?、無視する。
みのむし
Notebook PC HP G62
CPU: Intel(R) Core(TM)i5 M450 @ 2.40GHz
MEM: 4GB
Puppy Linux Quickset 5.1.1 JP
PC内蔵無線LANデバイス RTL8171(r8192se_pci)
アバター
みのむし
 
記事: 1164
登録日時: 08/09/10(水) 13:56
お住まい: 福岡市中央区草香江1-2-40-101号

Re: Flashサイトでブラウザが落ちるので、Google_Chrome ブラウザを試してみました

投稿記事by cygnus_odile » 10/01/23(土) 20:25

このフォーラムの Re: Google Chrome (by keitan) の記事にて紹介されている、
google_chrome-005.pet
を puppy の 4.3.1-JP にインストールして試してみました。

 朝日新聞のサイト (http://www.asahi.com/)にアクセスして、記事のリンクをいくつかタブで開いて見てしばらく放置したところ、 5つ中4つのタブの上の方に、
コード: 全て選択
「次のプラグインがクラッシュしました:/usr/lib/mozilla/plugins/libflashplayer.so」

とのメッセージが、トップ頁を開いているタブも含めて表示され、flash で表示されていたらしい部分は、黒くなりますが、ブラウザ自体は落ちることなく、ちゃんと記事は読めます。

 以上、ご参考まで。
 → 今後、当面は、朝日新聞サイトにアクセスするときは、Google chrome ブラウザでみることにします。 ところで、google_chrome-005.pet は最初から日本語対応しているんですね。何もしなくてもメニュー類の表示が日本語だ。動作も軽い! (この書き込みも、Chrome から)
cygnus_odile
 
記事: 665
登録日時: 09/08/16(日) 14:30

Re: Flashサイトでブラウザが落ちるので、Flashblockをインストールしました

投稿記事by みのむし » 10/01/25(月) 09:14

>「次のプラグインがクラッシュしました:/usr/lib/mozilla/plugins/libflashplayer.so」

Flash のバージョンは?

URL: about:plugins

Shockwave Flash
  ファイル名: libflashplayer.so
  Shockwave Flash 10.0 r42

※google_chromeでも同様。

>朝日新聞のサイト (http://www.asahi.com/)...

私の環境では、google_chromeで問題なく見れます。Flash もまったく問題ありません。
・Puppy 4.3.1JP
・google_chrome-puppy-4.31.pet(tomo3さん作、80.rc)
・Flash のバージョン 10.0 r42
・個人保存ファイルの残りサイズ 205M
※後、色々入れたので、ライブラリが追加されているかも知れません。
cygnus_odileさんの場合は、まず、Flash のバージョンを調べて
最新バージョン(10.0 r42)にアップデートしてみては?
みのむし
Notebook PC HP G62
CPU: Intel(R) Core(TM)i5 M450 @ 2.40GHz
MEM: 4GB
Puppy Linux Quickset 5.1.1 JP
PC内蔵無線LANデバイス RTL8171(r8192se_pci)
アバター
みのむし
 
記事: 1164
登録日時: 08/09/10(水) 13:56
お住まい: 福岡市中央区草香江1-2-40-101号

Re: Flashサイトでブラウザが落ちるので、Flashblockをインストールしました

投稿記事by シノバー » 10/01/25(月) 09:56

みのむし さんが書きました:>「次のプラグインがクラッシュしました:/usr/lib/mozilla/plugins/libflashplayer.so」
Flash のバージョンは?
URL: about:plugins
Shockwave Flash
  ファイル名: libflashplayer.so
  Shockwave Flash 10.0 r42.

RAM 4GB実装3.4GB認識 スワップなし
4.3.1JPqs0
Shockwave Flash 10.0 r42
google_chrome-puppy-4.31.pet

メニュー>システム>Topを走らせておき
朝日新聞のサイト (http://www.asahi.com/)にアクセスすると
またたくうちにプラグインがメモリを3GB使い切ります。5分ほど経つとプラグインがクラッシュ。google-chrome自身は生きています。

やはり朝日新聞のサイトには近づかないのが身のためですね。
最後に編集したユーザー シノバー [ 10/01/25(月) 12:07 ], 累計 1 回
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Re: Flashサイトでブラウザが落ちるので、Flashblockをインストールしました

投稿記事by みのむし » 10/01/25(月) 10:42

シノバーさん、返信どうも。

>4.3.1JPsq0

sq0 は、qs0 の間違いでは?

qs0 ... Quickset Puppy v.0

>メニュー>システム>Topを走らせておき

の意味もよく分かりません。
Google_Chrome を起動しての事ですよね。
メニューは2段目右端のページのアイコンとツールのアイコンの事でしょうか?
どちらのサブメニューにもシステムは出て来ません。

>またたくうちにプラグインがメモリを3GB使い切ります。

Puppy のインストール方法は(Frugal、Full)?
(私の環境は Frugalです。
Frugal なら個人保存ファイル>デスクトップ画面下部パネルの右端、残りサイズ を見るのでは?)
最初、205M>118M>117M でシノバーさんとは症状が違います。
コード: 全て選択
 最初、205Mあったのに、キャッシュも消去しても 122Mにしかなりません。
Puppy を再起動しても変化無し。
# cd /root
# ls -a
...
# cd .cache
google-chrome
# cd google-chrome
Cache
(最初、ここには3つのディレクトリが在り、そのうちCacheが2個ありましたので、/root/.cacheを再作成しました)
# cd Cache
...

5分間何もしないで放置していました所、落ちませんでしたが、
「次のプラグインがクラッシュしました:/usr/lib/mozilla/plugins/libflashplayer.so」が出ていました。

>やはり朝日新聞のサイトには近づかないのが身のためですね。

そう思います。原因は Flash にあるような気がします。
「WWWブラウザもほとんどのメモリをキャッシュで使用する」といったような事を何処かに書いてあったような...
みのむし
Notebook PC HP G62
CPU: Intel(R) Core(TM)i5 M450 @ 2.40GHz
MEM: 4GB
Puppy Linux Quickset 5.1.1 JP
PC内蔵無線LANデバイス RTL8171(r8192se_pci)
アバター
みのむし
 
記事: 1164
登録日時: 08/09/10(水) 13:56
お住まい: 福岡市中央区草香江1-2-40-101号

Re: Flashサイトでブラウザが落ちるので、Flashblockをインストールしました

投稿記事by シノバー » 10/01/25(月) 12:37

みのむし さんが書きました:qs0 ... Quickset Puppy v.0

でした。

>メニュー>システム>Topを走らせておき
パピーのメニューです。端末から top コマンドを実行しても同じです。
free コマンドでもメモリの使用量は分かりますが、topだとプロセス毎に分かるので。

みのむし さんが書きました:Frugal なら個人保存ファイル>デスクトップ画面下部パネルの右端、残りサイズ を見るのでは?)

ここの表示は何を表示しているかというと、けっこうややこしいです…… :(
基本は個人保存ファイル(pupsave)の残りサイズですが、RAMモードで起動したとき(pupmode=5)や、フラッシュメモリのとき(pupmode=13)などモードにより異なります。
viewtopic.php?f=32&t=1461&p=10510#p10387

/mnt以下を除くファイルシステムに何か置くとpupsaveは消費されます。たとえばPETのインストール(SFSは消費しない)、キャッシュやダウンロード(キャッシュやダウンロード先に/mnt以下を指定しておくと消費しない)。

ここの表示(基本はpupsaveの残りサイズ)に余裕があっても安心できません。free コマンドで見ることのできるRAM(実装RAM+スワップ)の消費量はこれとはまた別です。大きなプログラムが動作すると、こちらがいっぱいになって、そのプログラムが止まるか落ちる。あるいは他に影響の出ることもあります。
最後に編集したユーザー シノバー [ 10/01/26(火) 10:48 ], 累計 1 回
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Re: Flashサイトでブラウザが落ちるので、Flashblockをインストールしました

投稿記事by cygnus_odile » 10/01/25(月) 23:12

みのむしさん、シノバーさん、他 遅くなりましたが、アドバイス有難うございます。
当方の環境は、
Puppy Linux 4.3.1JP
firefox-3.6.pet 導入
googole_chrome-0.05.pet 導入
の状態です。flash player のバージョンはアドビのサイトの「Adobe Flash Player のバージョンテスト」にアクセスして確認したところ、
LNX 10,0,42,34
でした。まあ、google chrome ですと、asahi.com にて「flash player クラッシュ」の警告はでますが、Firefox や SeaMonkeyなどとは異なり、ブラウザ自体は落ちないのでよろしいかと思っています。
cygnus_odile
 
記事: 665
登録日時: 09/08/16(日) 14:30

Re: Flashサイトでブラウザが落ちるので、Flashblockをインストールしました

投稿記事by みのむし » 10/01/29(金) 16:44

cygnus_odileさん

 返信ありがとうございます(私の返信が遅れまして申し訳ありません)。
なお、cygnus_odileさんの記事(ここへのポスト)を パピーWiki に掲載してもよろしいでしょうか?
とりあえず、私の判断で以下のページを作成して掲載しますので、不都合の有る場合はご連絡してください。

アプリケーションの不具合報告
 何か良いタイトルがあれば....

 私の考えているのは、以下のページです。
 (ご要望があれば何なりと ...)
 私の主観で考えてしまいます。
 初心者の方の視点では、どうなのか...
 といった所が知りたいのです。


追加予定ページ

 ・アプリケーションの不具合報告
  現時点では、Puppy 4.3.1JP アプリケーションに関する、不具合報告

 ・初心者向けTips集
  Puppy に限らず Liux 全般についてのTips集です。
   前半はLinux全般、後半はPuppy について

  ・テキストのコピー&ペースト
  ・ウィンドウのドラッグ&移動
  ・Xの設定
みのむし
Notebook PC HP G62
CPU: Intel(R) Core(TM)i5 M450 @ 2.40GHz
MEM: 4GB
Puppy Linux Quickset 5.1.1 JP
PC内蔵無線LANデバイス RTL8171(r8192se_pci)
アバター
みのむし
 
記事: 1164
登録日時: 08/09/10(水) 13:56
お住まい: 福岡市中央区草香江1-2-40-101号

Re: Flashサイトでブラウザが落ちるので、Flashblockをインストールしました

投稿記事by cygnus_odile » 10/02/01(月) 06:51

みのむし さんへ、 お返事遅くなりましたが、
私の 当フォーラムへの 投稿記事 はご自由にお使い下さい。
好きなように編集引用していただいて結構です。
少しでも、 人のお役に立てるなら、幸いであります。
cygnus_odile
 
記事: 665
登録日時: 09/08/16(日) 14:30

Re: Flashサイトでブラウザが落ちるので、Flashblockをインストールしました

投稿記事by みのむし » 10/02/01(月) 09:58

>私の 当フォーラムへの 投稿記事 はご自由にお使い下さい。
>好きなように編集引用していただいて結構です。
>少しでも、 人のお役に立てるなら、幸いであります。

cygnus_odileさん、快くご了承して頂き有難うございます :D
みのむし
Notebook PC HP G62
CPU: Intel(R) Core(TM)i5 M450 @ 2.40GHz
MEM: 4GB
Puppy Linux Quickset 5.1.1 JP
PC内蔵無線LANデバイス RTL8171(r8192se_pci)
アバター
みのむし
 
記事: 1164
登録日時: 08/09/10(水) 13:56
お住まい: 福岡市中央区草香江1-2-40-101号

Flash Player 10.0.45.2

投稿記事by シノバー » 10/02/14(日) 22:42

AdobeからFlash Player 10.0.45.2 が出たので試してみました。
asahi.com でメモリを食いつぶして seamonkey が落ちる件、まったく変わっていません。

Adobeが悪いか、Adobeに追従して Flashを多用する Webデザイナーが悪いか…… 8)
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Re: FlashPlayer 10.1 で落ちなくなりました?

投稿記事by cygnus_odile » 10/06/24(木) 22:03

Adobe のサイトから、 flashplayer 10.1.53.64 の tar.gz ファイルを落としてきて、中身の、libflashplayer.so を、
/usr/lib/mozilla/plugins に入っていたものと置き換えて、browser 再起動すると、flashplayer の version が、10.1 となりました。
 そのせいか知りませんが、 asahi.com (朝日新聞)のサイトは、十個くらいタブを開いても落ちなくなったようデス。 それとも、asahi.com 側で改善が図られたのでしょうか?
(Puppy Linux 4.3.1J / Firefox 3.6.4 & SeaMonkey 2.0.5 & SeaMonkey 1.1.18)
cygnus_odile
 
記事: 665
登録日時: 09/08/16(日) 14:30

Asahiが変わった?

投稿記事by シノバー » 10/06/25(金) 11:31

cygnus_odile さんが書きました:asahi.com 側で改善が図られたのでしょうか?

Flashplayerの前のバージョンでも落ちなくなりました。どこを変えたんでしょうね?

Puppy Linux 4.3.1JPqs3
SeaMonkey 1.1.18 - adblock 無効
Flashplayer 10.0 r42
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

1つ前へ

Return to パピーリナックス日本語版

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]

cron