設定した「接続」情報を覚えてくれません

リリースされた日本語版に関するバグ、トラブル

モデレータ: 暇人, YoN, nyu

Re: 設定した「接続」情報を覚えてくれません

投稿記事by 新谷 » 09/11/16(月) 11:27

もう既に調査済みと思いますが、
/etc/rc.d/rc.shutdown の最後の方で、一応消すべきファイルは消すようになってますね。

/etc/rc.d/rc.shutdown 1011行目から
コード: 全て選択
rm -f /var/log/X*
rm -rf /tmp/*
rm -f /var/lock/LCK*
rm -f /var/run/*.pid
rm -rf /root/tmp 2> /dev/null #...note, not screening this out in any of above save modes.
rm -rf /root/.thumbnails/* 2> /dev/null

これより前のセーブファイルに複写する時に、何かトラブルがあるのかしらん。
新谷
 
記事: 934
登録日時: 08/10/09(木) 18:52
お住まい: 大阪

Re: 設定した「接続」情報を覚えてくれません

投稿記事by 新谷 » 09/11/16(月) 11:46

パピーのセーブファイルの内容って /initrd/pup_ro2 にあるんでしたっけ?
コード: 全て選択
rm -rf /tmp/*  /initrd/pup_ro2/tmp*
rm -f /var/lock/LCK*  /initrd/pup_ro2/var/LCK*
rm -f /var/run/*.pid  /initrd/pup_ro2/var/run/*.pid

とか何とかでは駄目っぽいですかね....もの凄いやっつけ仕事ですが。

....ごめんなさい、続きは↓で
シノバー さんが書きました:snapmergepuppyに問題アリですね。
この続きは、開発者の話し合い>4.3.1JP-RC3で↓
http://sakurapup.browserloadofcoolness.com/viewtopic.php?f=28&t=1444&start=45#p10285
新谷
 
記事: 934
登録日時: 08/10/09(木) 18:52
お住まい: 大阪

Re: 設定した「接続」情報を覚えてくれません

投稿記事by cygnus_odile » 09/12/01(火) 22:55

4.3.1JP final 版で、起動時に 無線LANに自動接続しないことが多々あるのですが、よく見てみると、
通常起動時に無線LANに自動接続するときは、インターフェイスが、
 eth0 : イーサネット、 eth1 : ワイヤレス
なのに、自動接続しないときは
 eth0 : ワイヤレス、 eth1 : イーサネット
のように、認識されていることが判りました。再起動して元に戻ったりするのですが。
(パソコンは Dell Latitude D600 です。 無線インターフェースは、 pci: Intel LAN 2100 3B Mini-PCI Adapter)
420p1JP では、こんな現象はありません。
cygnus_odile
 
記事: 665
登録日時: 09/08/16(日) 14:30

Re: 設定した「接続」情報を覚えてくれません

投稿記事by シノバー » 09/12/02(水) 22:02

cygnus_odile さんが書きました:通常起動時に無線LANに自動接続するときは、インターフェイスが、
 eth0 : イーサネット、 eth1 : ワイヤレス
なのに、自動接続しないときは
 eth0 : ワイヤレス、 eth1 : イーサネット

こういう問題は昔からありますね。2つのインターフェースを担当するカーネルモジュールが異なっているならば、モジュールのロード順を固定してやれば解決するはずです。
昔々カーネル2.4の時代にVineで、rc.localにmodprobeを記述して解決したことがありました。
コード: 全て選択
/sbin/modprobe モジュールA
/sbin/modprobe モジュールB

カーネル2.6で、そしてパピー 4.3.1JPで、rc.localにそれを書いて間に合うのかどうか?
rc.sysinitの途中でそれを書かないといけないかも。

dmesg や
/tmp/bootkernel.log
/tmp/bootcnt.txt
/tmp/bootsysinit.log
あたりを覗くとヒントがあるかもしれません。
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Re: 設定した「接続」情報を覚えてくれません

投稿記事by cygnus_odile » 09/12/02(水) 23:31

シノバーさん、ご教示ありがとうございます。 (とりあえず、昨夜から本日にかけては、自動接続しているのですが。)
各々のドライバモジュールは、
 イーサネット  tg3 pci: Broadcom BCM5702X Gigabit Ethernet
 ワイヤレス   ipw2100 pci: Intel LAN 2100 3B Mini PCI Adapter
なのですが、一旦 両方 rmmod してから
modprobe tg3
modprobe ipw2100
の順に実行させて読み込ませるようにすればよいのでしょうか。 また、記述を加えるファイルとしては、
/etc/rc.d/rc.network
の最初の方にしてみるのではどうでしょうか? 平日はあまり時間がなく、私にはハードルが高そうなので、申し訳ありませんが次の週末にでもトライしてみようと思います。
cygnus_odile
 
記事: 665
登録日時: 09/08/16(日) 14:30

Re: 設定した「接続」情報を覚えてくれません

投稿記事by シノバー » 09/12/03(木) 09:04

cygnus_odile さんが書きました:一旦 両方 rmmod してから
modprobe tg3
modprobe ipw2100
の順に実行させて読み込ませるようにすればよいのでしょうか。 また、記述を加えるファイルとしては、
/etc/rc.d/rc.network
の最初の方にしてみるのではどうでしょうか? 

なるほど、それが確実ですね。
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

rc.network-auto

投稿記事by シノバー » 10/02/10(水) 15:40

4.3.1JPqs0 固有、あるいは NIC(有線LAN)の自動検出と接続で2010年2月8日まで配布していた rc.network に限った問題です。

/etc/rc.d/rc.network の 29nov09 バージョンは、 rc.network が実行された時点で初期化の終わっていないインターフェースの設定は自動的に削除します。このため、 一部USB接続などの(有線/無線)NICの設定が再起動でご破算になるという問題があります。

rc.network-auto-100209.gz で解消されています。上記トピック NIC(有線LAN)の自動検出と接続 をご覧ください。
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

1つ前へ

Return to パピーリナックス日本語版

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[2人]