Precise-571JPで Canon iP2500 の印刷

リリースされた日本語版に関するもの

モデレータ: 暇人, YoN, nyu

Precise-571JPで Canon iP2500 の印刷

投稿記事by varridu » 14/07/29(火) 11:00

Precise-571JPで Canon iP2500 の印刷ができたので、その案内です。
主な手順は2点
1.rpmファイルをダウンロードし、インストールする。
2.シンボリックリンクを作成する。
です。

1.rpmファイルをダウンロードし、インストールする。
ftp://download.canon.jp/pub/driver/bj/l ... 1.i386.rpm をダウンロード。
http://software.canon-europe.com/softwa ... 1.i386.rpmにて27215.tgzをダウンロード後解凍し、cnijfilter-ip2500series-2.70-1.i386.rpmを入手。
それぞれ、rpmファイルをクリックするとインストールされる。(571JPでは、petでなくてもrpmそのままで設定可能だった。)

2.シンボリックリンクを作成する。
プリンターを追加してもテスト印刷さえ出来ない。デバッグすると、 libcnbp*311.so (*は様々)が不足していることが判明した。
/usr/libには、libcnbp*311.so  がなく、代わりに libcnbp*311.so.6.50.1 などがあることを確認した。
したがって、それぞれ、 libcnbp*311.so として取り扱われる様に symbolic link した。

symbolic linkファイル作成操作例:
urxvt(端末)で、
# cd /usr/lib
# ls lib*311*
すると、
libcnbpcmcm311.so.6.50.1
libcnbpcnclapi311.so.3.3.0
libcnbpcnclbjcmd311.so.3.3.0
libcnbpcnclui311.so.3.3.0
libcnbpess311.so.3.0.9
libcnbpo311.so.1.0.2
と、対象ファイルが表示されるので、それぞれ ln -s libcnbpxxx311.so.yyy libcnbpxxx311.so を実施する。(xxx,yyyは様々)
例:
# ln -s libcnbpcmcm311.so.6.50.1 libcnbpcmcm311.so
(私は、ls で表示されているファイル名を選択してマウスの中クリックでペーストする機能を利用して、ファイル名の入力ミスを避けた)
varridu
 
記事: 4
登録日時: 14/07/22(火) 11:33

Re: Precise-571JPで Canon iP2500 の印刷

投稿記事by 486HA » 14/07/29(火) 23:18

自力で Canon iP2500の印刷が出来るようになったのなら、いまさら余計なことかもしれませんが、
実のところ5年ほど前にPatriotさんによっPuppy用のドライバーは公開されています。
http://www.murga-linux.com/puppy/viewtopic.php?t=47444

自力で克服してこそ、ノウハウの蓄積になります。
CORE-i7-6700HQ uEFI ram:8GB
Full: Quirky Xerus-64 8.2
save2dir: Tahr 6.0.6(32/64), Slacko 6.9.9(32/64),Xenialpup 7.0.8.1
Slimjet 15.0.3.0(32/64)
486HA
 
記事: 1142
登録日時: 11/03/06(日) 14:31

Re: Precise-571JPで Canon iP2500 の印刷

投稿記事by varridu » 14/07/31(木) 19:16

初稿では無用な情報なので触れていませんが、http://www.murga-linux.com/puppy/viewtopic.php?t=47444 は本トピックのご案内前に確認しています。ここで、Patriotさんが提供していたであろうdriverを今は入手できません(not exist)。

さて、486HA さん、困りましたね。 ずいぶん上から目線の記述をされる方ですね。
しかも、トピックのURLだけを案内したら、あんな11ページにもなるものでも、現実に情報を必要とされている方は読みますよ。それで後日「実はドライバーはダウンロードできません。」とでもコメントするつもりだったのでしょうか?

現実に情報を必要とされている方の被害が無いように、あえて強く述べさせていただきます。

700件を超える投稿でこのフォーラムに貢献されているのですから、URLを紹介する場合は「その内容が現在有効である」ことを確認してから記載ください。
さもないと、参照者にとって不要で且つ混乱するだけの文字列にしかなりません。ご協力よろしく!

-----------------------------------------------------------------------------
以下 http://www.murga-linux.com/puppy/viewtopic.php?t=47444 確認内容:
2つめの投稿の記述中段の
Canon drivers merged into v3.00:
にある、
3. ip2500 series download
が、本件対象のiP2500用ドライバーの件。
しかしこの"download"をクリックすると、 http://www.datafilehost.com/d/396447ff にジャンプしますが、 "The file you requested (id 396447ff) does not exist. " と、ファイルがないことを示すのみで入手できません。(なお、このページに出る[download now]をダウンロードすると、Norton先生に危険ファイルと判断されて削除されましたので、クリックしないようご案内します。)
varridu
 
記事: 4
登録日時: 14/07/22(火) 11:33

canonプリンタのドライバ

投稿記事by シノバー » 14/07/31(木) 19:43

子犬でプリンタ/スキャナをインストールする方法 viewtopic.php?f=23&t=2638
でも触れていますが、本家フォーラム http://www.murga-linux.com/puppy/ に不具合があったのか、アップされていたファイルが現在ダウンロードできないものが多々あります。

canon提供のプリンタドライバは、必要な作業(/usr/lib 内のリンク)を、パピーでは実行できないスクリプトで実行しているために問題が生じます。

canon提供のプリンタドライバ.deb をインストール後、devx のSFSをロードして、端末から ldconfig を実行すれば、たぶんOKだと思われます。初心者でも分かりやすい方法が提供されるとよいのですが…。
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Re: Precise-571JPで Canon iP2500 の印刷

投稿記事by 486HA » 14/07/31(木) 21:54

varridu さんが書きました:URLを紹介する場合は「その内容が現在有効である」ことを確認してから記載ください。
さもないと、参照者にとって不要で且つ混乱するだけの文字列にしかなりません。ご協力よろしく!

私が実際に利用したのは、後述するキャノンの海外サイトから入手したドライバーですが、
後にPatriotさんが公開されたものも動作確認したことがあります。
現在も残っているものと思っていましたが、現状を確認せず混乱を招いたことをお詫びします。
現時点で Canon プリンタードライバーは、rcrsn51さんによって整理されていますが、
↓ここでもip2500は、無くなっています。
http://murga-linux.com/puppy/viewtopic.php?p=644116#644116

私が以前(5年ほど前ですが)利用したドライバーは現在でもダウンロードできます。
http://support-ph.canon-asia.com/contents/PH/EN/0900718901.html
長いページの殆ど最後のほうで、cnijfilter-ip2500series-2.70-1.i386.rpmがダウンロードできます。
[quote="varridu"]
1.rpmファイルをダウンロードし、インストールする。
ftp://download.canon.jp/pub/driver/bj/l ... 1.i386.rpm をダウンロード。
http://software.canon-europe.com/softwa ... 1.i386.rpmにて27215.tgzをダウンロード後解凍し、cnijfilter-ip2500series-2.70-1.i386.rpmを入手。[/url]
ダウンロード元とタイムスタンプこそ違っていますが、中身は全く同じものです。
パーミッションが与えられていないため、記事の添付ファイルを見ることができません
CORE-i7-6700HQ uEFI ram:8GB
Full: Quirky Xerus-64 8.2
save2dir: Tahr 6.0.6(32/64), Slacko 6.9.9(32/64),Xenialpup 7.0.8.1
Slimjet 15.0.3.0(32/64)
486HA
 
記事: 1142
登録日時: 11/03/06(日) 14:31


Return to パピーリナックス日本語版

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]