puppy431JPでの動画再生

リリースされた日本語版に関するもの

モデレータ: 暇人, YoN, nyu

puppy431JPでの動画再生

投稿記事by yayo » 15/12/05(土) 22:57

Puppy 4.3.1JP2012 上での動画再生ができません。

環境
WinXPと431JPの.exe インストーラー版とのデュアルブート
CPU : AMD Duron, 1.3GHz ; メモリ 128MB

元から入っているメディアプレイヤーでは映像が激しく乱れていて紙芝居レベル以下でしたので色々調べたんですが…
当フォーラム内を一通り検索してMPlayer, SMPlayer, VLCそれぞれの.petまたは.sfsファイルを導入してみましたが、再生されないどころか起動すらしません。
ただ、winXP上でダウンロード&インストールしたSMPlayerとVLCはwinXP上で問題なく再生できるし早送り機能を乱用(大幅に早送りするホットキーを連打したりめちゃくちゃに)しても大丈夫なんですが、pup上ではwine経由で何とか起動させることができるんですがやはり映像がでません。
あと気になるのはどれかの.petファイルを導入した際に「欠けているパッケージ qt」みたいなメッセージがありましたが、それと同時に導入そのものは成功したようなのでよく意味がわかりません。

なお、.sfsは/mnt/home/に置いてSFS-Load on-the-flyでロードしてますし、.petはクリックすればいいだけのはずですから配置ミス等はないかと思います、たぶん…
それと、プログラムが起動に失敗した時などにそれに関する詳しい情報を記録するようなファイルは自動生成されますか?
素人ながらに思いつくのは以下の5つなんですが、どういったことをこなせば動画再生できるんでしょうか。
できればSMPlayerをwineを経由せずに使いたいです…

1) 431JPが最近作成された動画の再生を苦手としている
2)AMD Duron と 431JP との相性問題
3)qtとやらがない(もしくは必須のものがない)
4)動画の画質が高すぎる
5)その他

お知りになりたい情報があれば書きます。
yayo
 
記事: 3
登録日時: 15/11/18(水) 17:55

Re: puppy431JPでの動画再生

投稿記事by ルビー » 15/12/06(日) 10:29

yayoさん、こんにちは。
RAM128MBでWinXPをお使いとはかなりのツワモノの方のようですが、パピーで見られない動画の形式は何でしょうか?

以前431JP2012を使ってましたが、付属のメディアプレーヤーgxineでごく普通の形式の動画(MPG、WMV)が見られなかった事は無かったと思います。DVDも見られましたし。
Eee PC 4G-X CeleronM 900MHz RAM512MBでした。RAMの容量が違いすぎるのであまり参考にならないかもですが。

試しにEee PC 901X AtomN270 1.6GHz RAM1GBで431JP2012をCD起動させて、MP4 1920×1080の重たい動画をgxineで再生させてみました。何とか頑張って再生してる感じで、音声も出ませんがまあ見られなくもないです。紙芝居ではなくて一応動画にはなってます(^^;。
901Xの571JPでも、MP4ファイルを付属のGNOME-MPlayerで再生してみましたが、こちらも何とかギリギリで見られる程度です。
Thinkpad R40 Pentium4-M 1.8GHz RAM256MBで431JP2012もあってyayoさんの環境に近いので一番参考になりそうですが、今は手元にないので試せません。これはYouTubeもそこそこ見られます。

とりあえずyayoさんの431JP2012で、YouTubeは見られるのでしょうか。
メモリ128MBではパピーと言えども、動画を楽しむにはかなり工夫が必要に思います。
RAMモードで起動しても同じ現象でしょうか。
インストールもfrugalだと思いますが、個人保存ファイルのサイズはどれくらいか。swapの有無とか。
WindowsでOKでもパピーでは問題が出る事は、動画に限らずあります。私もそれではまりました。でもWindowsに戻る気はないですが。

ここはパピーの話し合いですので、板違いだと思います。
私のレスも一度削除しますから、お手数ですが初心者のヘルプに移動をお願い致します。

追伸
削除できなくなっちゃったから、このままでOKです(^^;。
もしくは、この板でも良かったのかしら。すみません。
最後に編集したユーザー ルビー [ 15/12/06(日) 12:27 ], 累計 1 回
アバター
ルビー
 
記事: 500
登録日時: 14/11/24(月) 12:12

Re: puppy431JPでの動画再生

投稿記事by Endeavor_wako » 15/12/06(日) 11:23

yayo さんが書きました:Puppy 4.3.1JP2012 上での動画再生ができません。

環境
WinXPと431JPの.exe インストーラー版とのデュアルブート
CPU : AMD Duron, 1.3GHz ; メモリ 128MB


1) 431JPが最近作成された動画の再生を苦手としている
2)AMD Duron と 431JP との相性問題
3)qtとやらがない(もしくは必須のものがない)
4)動画の画質が高すぎる
5)その他

お知りになりたい情報があれば書きます。


XPで視聴可能ということであれば 5)かしらん。

まず、431JP2012が持っているビデオ周り(サーバー、ドライバなど)がお使いのPCに適合しているか? 汎用サーバ(xvesa)で動いていると動画は厳しいかもしれません。
また、インストールしたプレイヤーのバイナリがAMDプロセッサの拡張命令に対応していないと、やはりPCの性能を100%発揮できないと思います。

アプリケーションが起動するかどうかは、端末から起動することでエラーメッセージを調べる方法があります(エラーを吐かないアプリケーションもありますが)。
ライブラリについては、同様に端末から lddを使って調べることができます。

外していたらすみません。
Main:lenovo ThinkPad R500,LinuxMint17.2Xfce(x64)
Sub:ASUS eeePC 1001PX,Slitaz rolling, LM17.2Xfce(x86)に変えました
Old sub:Matsushita CF-R2,Slitaz rolling

Puppyを使わなくなって久しい今日この頃。引き続き、会話シュミレーターは無視する方向で。
Endeavor_wako
 
記事: 378
登録日時: 09/09/18(金) 01:54

Re: puppy431JPでの動画再生

投稿記事by タロ兵衛 » 15/12/06(日) 19:31

yayo さんが書きました:1) 431JPが最近作成された動画の再生を苦手としている
2)AMD Duron と 431JP との相性問題
3)qtとやらがない(もしくは必須のものがない)
4)動画の画質が高すぎる
5)その他

拝見したところ、メモリ不足でスワップファイルへのアクセスが頻繁に起きて紙芝居以下になっているんではないかと思います
128MBでも起動しますが、必須メモリ容量は256MBです。
もし、XPを削除してよいのであれば、フルインストールという方式でインストールし直すと動作するかも知れません

で。
1)のテストです
http://tarobeeee.web.fc2.com/test.html
の画像を試してみて下さい。(ダウンロードしてやって下さい。オンラインではネット系の問題があった場合の切り分けができないので)
2)は多分問題ないです。以前持っていたDuronのPCでもソコソコ再生していましたので。
3)は先ずは標準のGNOME MPlayerで様子を見ましょう
4)先ほどのテスト画像が正常に見えるようになってから挑戦しましょう
5)グラボ?との相性はあるかも知れません。XPのHDDにインストールするときにデフラグはされましたでしょか?HDDが整理されない状態でPuppyをフルーガルインストールすると、速度低下する可能性があります。
ただ、荒れた状態のHDDをデフラグすることはHDDにストレスですので、重要なファイルのバックアップは忘れずに。

メモリの具合はメニューから、システム→ハードウェア情報-でシステム情報のウィンドウが起動します
そこの左ペインから→devices→MemoryでFree Memory を見てみて下さい
ここの数値で数十メガは欲しいところです。
下記はメモリ128MBで試したキャプチャです。簡単なムービーなら再生できました。
試された画像ファイルは市販のDVDとかですか?
VirtualBox_571_06_12_2015_07_53_18.png
パーミッションが与えられていないため、記事の添付ファイルを見ることができません
最後に編集したユーザー タロ兵衛 [ 15/12/08(火) 07:45 ], 累計 1 回
暫定メインマシン(本体2000円Junk+余剰部品)
AMD Athlon 64 Dual Core 4400+
tahrpup 6.0.5 シンプル (PAE)-5
Slacko64 Puppy - 6.3.0
アバター
タロ兵衛
 
記事: 316
登録日時: 08/07/08(火) 00:11
お住まい: よこはま

Re: puppy431JPでの動画再生

投稿記事by ルビー » 15/12/07(月) 13:23

Thinkpad R40 RAM256MBの431JP2012で、重たいMP4 1920×1080の動画をgxineで再生してみました。
音は出ませんが、予想以上の出来でパピーは再生してくれました。
お世辞にも滑らかな動画とは言えませんが、このパソのスペック考えたら上出来だと思います。
あ、でも一応swap264MB作ってます(^^;。
アバター
ルビー
 
記事: 500
登録日時: 14/11/24(月) 12:12

Re: puppy431JPでの動画再生

投稿記事by yayo » 15/12/08(火) 20:17

返信ありがとうございます。諸事情により対応が遅れました。

ルビー さんが書きました:1.パピーで見られない動画の形式は何でしょうか?
2.とりあえずyayoさんの431JP2012で、YouTubeは見られるのでしょうか。
3.RAMモードで起動しても同じ現象でしょうか。
4.インストールもfrugalだと思いますが、個人保存ファイルのサイズはどれくらいか。
5.swapの有無とか。


1.動画形式はmp4です。H264で見たいのでそのままで見られるのであればなお嬉しい。
2.使用できるブラウザの関係で快適ではないものの見れることは見れます(ただ、不便なのでwinXP上ではフリーのダウンロードツールで落としてから見ていますのでオンラインで利用することはありません)。
3.やり方がよくわかりません。シノバーさんのブログには「パピーをRAMモードで起動するには、パピー起動時にオプション'pfix=ram'を加える。」とあるんですがパピー起動時に文字入力できる画面を確認できません。
4.pupsave.4fsのサイズは1024Mにしました。実メモリに対して大きすぎる値だとデメリットがあったりするんでしょうか?また、Puppy_Linux_431JP2012_Installer.exeを使っているので、すでにインストールされているものを思っており、frugal / full インストールというのはCDやUSBから起動させた人がする必要があるものと思っていたのですが、Puppy_Linux_431JP2012_Installer.exeを使った場合でもfrugal または full インストールする必要があるんでしょうか?
5.pupswap.swpはあります。390MBでした。

次にメディアプレイヤーに関して
gxine : デフォルトメディアプレイヤーであるこれを使用したときの映像をが紙芝居以下の乱れたものだったんですが、プレイヤーの画面サイズを変更してみたら正常な映像が表示されました。が、ごく小さなサイズの画面でしか正常な表示はされず、広げると再びひどく乱れた映像に変わります。これでは使う価値がないように思えます。

ffplay : 一部のH264/mp4の動画はわりとスムーズに再生されますが、紙芝居になるものもあります。
XP上でフリーのソフト落として画質下げたりすればいけなくもないかなという感じですが、XP起動させるんならXP上で動画見ればいいということになるので根本的な解決になっていない… とはいっても使える。

MPlayer : 端末から下記のようにコマンド入力して起動させようとしましたが、エラーが返されます。
# mplayer /root/aaa.mp4
mplayer: error while loading shared libraries: libavutil.so.49: cannot open shared object file: No such file or directory
ファイル名・フォルダ名は間違わないように上記のように名前をaaaにしてroot直下に置いたのにそんなもんねーよとか言われるんですね…

SMPlayer : メニュー - マルチメディア 内にはSMPlayerと表示されていますがクリックしても起動しません。
任意の動画を右クリックして「対応アプリを設定」からシェルコマンド「SMPlayer "$1"」を入力して使用コマンドをクリックし、試しに再起動なんかもしましたが起動できませんし関連付けもされてません。
端末から起動を試みるとこういうことだそうです。Qtとやらが足りないってことですかね?
# smplayer
smplayer: /lib/libc.so.6:version 'GLIBC_2.11' not found (required by /usr/lib/libQtGui.so.4

タロ兵衛 さんが書きました:1)のテストです
http://tarobeeee.web.fc2.com/test.html
の画像を試してみて下さい。(ダウンロードしてやって下さい。オンラインではネット系の問題があった場合の切り分けができないので)
2)は多分問題ないです。以前持っていたDuronのPCでもソコソコ再生していましたので。
3)は先ずは標準のGNOME MPlayerで様子を見ましょう
4)先ほどのテスト画像が正常に見えるようになってから挑戦しましょう
5)グラボ?との相性はあるかも知れません。XPのHDDにインストールするときにデフラグはされましたでしょか?HDDが整理されない状態でPuppyをフルーガルインストールすると、速度低下する可能性があります。
ただ、荒れた状態のHDDをデフラグすることはHDDにストレスですので、重要なファイルのバックアップは忘れずに。

メモリの具合はメニューから、システム→ハードウェア情報-でシステム情報のウィンドウが起動します
そこの左ペインから→devices→MemoryでFree Memory を見てみて下さい
ここの数値で数十メガは欲しいところです。


1)この動画はすんなり再生できました。
2)再生できないというのは一部思い違いだったようなので、そのようですね。
3)431JPにプリインストールされているのはMPlayer であり gnome-mplayerではないと思います。
gnome mplayer は puppy 5.x系のものみたいですが、PETget マネージャから取得して試すべきでしょうか?
4)XP使用時に取得した動画のうち見れるものと見れないものがありました。H264でもスムーズに再生されるものもあったり紙芝居になるものもあったり・・・ 変換して多少品質を落とせば問題ない、かもしれません。
5)グラボ自体があんまりよくないですからね。分かってたと言えば分かっていましたが、たぶんグラボの性能面からして、厳しいんでしょうかね。
そしてルビーさんへの返信とも重複しますが、Puppy_Linux_431JP2012_Installer.exeを使っているので、すでにインストールされているものを思っており、frugal / full インストールというのはCDやUSBから起動させた人がする必要があるものと思っていたのですが、Puppy_Linux_431JP2012_Installer.exeを使った場合でもfrugal または full インストールする必要があるんでしょうか?一応デフラグはしっかりとやっておきましたが…

Free memoryを確認してみたところ平均で4MBしかありませんでした、これですかね、紙芝居動画の原因は。frugalもしくはfullインストールすれば増えるんでしょうか?
yayo
 
記事: 3
登録日時: 15/11/18(水) 17:55

Re: puppy431JPでの動画再生

投稿記事by タロ兵衛 » 15/12/09(水) 00:46

3)431JPにプリインストールされているのはMPlayer であり gnome-mplayerではないと思います。
これは失礼しました。同じだと思ってました。gnome-mplayerをわざわざ入れる必要はなくて、動作の確認が終わるまでは、標準のプレーヤーのままで良いと思います

Puppy_Linux_431JP2012_Installer.exeを使った場合でもfrugal または full インストールする必要があるんでしょうか?一応デフラグはしっかりとやっておきましたが…
Installer.exeの場合、frugalとなっているはずです。
この場合、OSの機能を一旦メインメモリのRAMディスクに読み込み、プログラムはここから実行されます。
これによりPuppyはプログラムの起動が速く、古いPCでもサクサク動作するわけです(他にも色々工夫はありますが代表的な部分です)。
このため、同クラスのLinuxや、Windowsよりも多くのRAMを必要とします。

もし、RAMが少なくpuppyを使おうとするならば、この部分を我慢して(最初に読み込むことをやめる)他のLinuxと同じように、都度HDDから読み出すようにすることで、メモリは稼げます。これをpuppyの世界ではフルインストールと呼んでいます。ただし、HDDのフォーマットがFATやNTFSではだめで、Linux専用のフォーマット(ext4など)にする必要があります。このフォーマットはWindowsからは見えないので、XPはあきらめる必要があります。(パーティションを切り直すなどすれば、デュアルブートは可能です)

小さな動画が再生できて、フリーのメモリが4MBということなので、断定はできませんが、メモリ不足が原因だと思います。
・・・歯切れの悪い回答で申し訳ないです。
暫定メインマシン(本体2000円Junk+余剰部品)
AMD Athlon 64 Dual Core 4400+
tahrpup 6.0.5 シンプル (PAE)-5
Slacko64 Puppy - 6.3.0
アバター
タロ兵衛
 
記事: 316
登録日時: 08/07/08(火) 00:11
お住まい: よこはま

Re: puppy431JPでの動画再生

投稿記事by ルビー » 15/12/09(水) 09:28

yayo さんが書きました:返信ありがとうございます。諸事情により対応が遅れました。

いいえ、お気になさらず。マイペースで良いと思います。

frugalインストールはまるでWindowsのアプリケーションソフトの様に、一つのフォルダを間借りして組み込まれます。コバンザメみたいな感じ(^^;。
yayoさんのもfrugalです。431JP2012はデフォルトで/mnt/home/puppyに一式がインストールされます。

個人保存ファイルのサイズも1GBあれば十分だと思います。逆に大きすぎてバックアップを取る時に、時間が掛かりませんか。ちなみに私のは256MBです。小さっ。
ハードディスク上に作成された個人保存ファイルは、swap的な働きもしてくれます。でも所詮は仮想メモリですので、実メモリと同じパフォーマンスでは働きません。この辺はWindowsと同じ理屈です。
MP4の動画がうまく再生できない一番の原因はタロ兵衛さんも書いてる通り、実メモリの不足だと思います。
メモリ128MBでフルHDのMP4 H.264動画がバキバキに動いたら、プレステなんていりません(^^;。

おそらくyayoさんが納得いかないのは、Windowsでもそこそこは見られるのに何で軽いはずのパピーで見れないのって事だと思います。
お使いのパソが自作かどうかは不明ですが、ほとんどのパソコンはWindowsに合わせて最適化されています。パピーの画像処理能力が劣っている訳ではなくて、不利な条件の中で健気に頑張っていると思います。

私がテストで使った動画は、Xacti DMX-HD1000のMP4 H.264 1920×1080です。
Thinkpad R40のスペックからして期待はしていませんでしたが、全画面表示で再生してもそこそこは見られました。音は出ないし一生懸命画面を描画してる感じですが、ここまで再生した事の方が驚きに思います。
gxineの設定はデフォルトのままです。
MP4で見られる物と見られない物があるそうですが、同じMP4の規格でも実装の具合が微妙に違っていたりとかなり複雑な世界の様です。あまり動画関係には詳しくはありませんけど。
パピーでもう少し動画環境を改善したいのであれば、実メモリの空きを増やす為にフルインストールはやる価値があるかもしれません。ただし、劇的に改善されるとも思えませんし、Windowsとの共用も難しくなります。

RAMモードとは個人保存ファイルを読み込まずにパピーを初期設定で起動させる方法です。Windowsのセーフモードみたいな物です。何か問題が起きた時に、問題の切り分けに役立ちます。
パソを起動時にWindowsとパピー二択のメニューが出て、パピーを選んだ後に通常とオプション起動選択のメニューが出ないでしょうか。そのメニューの中にRAMモードがあります。
アバター
ルビー
 
記事: 500
登録日時: 14/11/24(月) 12:12

Re: puppy431JPでの動画再生

投稿記事by ルビー » 15/12/10(木) 13:14

タロ兵衛さん
役に立つ事なのだし、HOWTOにテスト用動画のスレを再アップされてはどうでしょうか。
SLジャコバイト号のリンクはこのスレにもありますが、このスレがやがて埋もれてしまったらリンクを探して使うのも難しくなると思うし。
このトピック参照でリンクを貼るにも、スレッドに動画テストの趣旨が書かれてあった方が分りやすいですし。
アバター
ルビー
 
記事: 500
登録日時: 14/11/24(月) 12:12

Re: puppy431JPでの動画再生

投稿記事by タロ兵衛 » 15/12/10(木) 15:21

ラジャ!
暫定メインマシン(本体2000円Junk+余剰部品)
AMD Athlon 64 Dual Core 4400+
tahrpup 6.0.5 シンプル (PAE)-5
Slacko64 Puppy - 6.3.0
アバター
タロ兵衛
 
記事: 316
登録日時: 08/07/08(火) 00:11
お住まい: よこはま


Return to パピーリナックス日本語版

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[4人]