日本語キーボードで大括弧 ']' が打てない('\'になる)

よく聞かれる問題とその回答

モデレータ: 暇人, YoN, nyu

日本語キーボードで大括弧 ']' が打てない('\'になる)

投稿記事by シノバー » 11/10/16(日) 08:19

パピー日本語版では問題ないはずですが、英語版の Puppy/Puppletを日本語化したとき、日本語キーボードに設定しても大括弧 ']' が '\' になることがあります。原因は多くの Puppy/Pupplet が使っている woofにある xorgwizardのバグです。
いくつか方法はありますが、比較的簡単だと思えるもの2つを紹介します。

解決法1
/etc/X11/xorg.conf をテキストエディタで開き、次の部分を探します。
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "jp" #xkeymap0
EndSection

このうちで "XkbModel" が "pc102" に設定されているところが誤りです。正しくは "jp106"。
修正後:
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "jp106"
Option "XkbLayout" "jp" #xkeymap0
EndSection

修正した /etc/X11/xorg.conf を保存し、Xをリスタートします。

解決法2
仮想端末を開き、「keymap-set --load」とタイプします。
コード: 全て選択
# keymap-set --load
Loading "jp106" keyboard map...

このように返事がかえってくればOK。Xのリスタートは不要で、この後はただちに ']' が 使えます。
keymap-set コマンドは最近の Puppletの多くで使えるほか、 lang_pack_ja-1.4 以降に同梱されています。 また lang_pack_ja-1.4 以降では PCを再起動すると日本語キーボードのこの問題が自動的に修復されるようになっています。
viewtopic.php?f=25&t=1937
The bar master, Shino's Bar
http://paper.cup.com/
アバター
シノバー
 
記事: 3080
登録日時: 09/03/21(土) 00:05

Return to FAQ

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]