python3.2 以降を使いたい

パピーリナックスを初めて使う方

モデレータ: 暇人, YoN, nyu

python3.2 以降を使いたい

投稿記事by angel » 17/12/12(火) 10:19

tahrpup 6.0.5 日本語化版シンプル (PAE)をサブ機として使っているのですが、python3.2以降をインストールする方法が分かりません。
お分かりの方ご教授願います。
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

Re: python3.2 以降を使いたい

投稿記事by thinkpadnerd » 17/12/12(火) 20:45

libpython3.4_3.4.3
python3.4_3.4.3
python3.4-minimal_3.4.3

の3つをパッケージマネージャから入れてみました。予めパッケージマネージャのデータベースを更新しておく必要があるかもしれません。また、用途によっては、上記以外のパッケージも必要かもしれません。

添付画像は、バージョンを表示させたところです。
/usr/bin/python は python2.7 へのリンクになっています。リンク先を python3.4 に変更すればよさそうに思えますが、puppy の既存のプログラムは python 2系 を使うらしいので、まずいことが起きるかもしれません。

本家フォーラムに、同じような質問が出ていました。
http://www.murga-linux.com/puppy/viewtopic.php?p=955139

python 3系を 2系とは別の場所に置いて、パスを指定して動かすという方法が提案されています。(しかし、パッケージマネージャを使ってインストールすると、決まった場所に入ってしまいます。2系と3系は別のフォルダになってはいますが)

実験なさる場合は、予め save file のバックアップを取っておくほうがよさそうです。
添付ファイル
capture9795.png
ThinkPad T42 (Puppy 412 / Lupu 528)
CPU Pentium M 1.6GHz, RAM 512MB
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606 / Xenial 7.5)
CPU AMD C-50 1.0GHz, RAM 4GB
thinkpadnerd
 
記事: 559
登録日時: 15/10/25(日) 14:00

Re: python3.2 以降を使いたい

投稿記事by angel » 17/12/12(火) 21:51

thinkpadnerdさん コメント・情報ありがとうございます。
私の使っている環境では、ターミナルでpythonと打つと以下のようになっています。

sh-4.3# python
Python 3.1.4 (default, Mar 14 2012, 22:42:45)
[GCC 4.3.4] on linux3
Type "help", "copyright", "credits" or "license" for more information.
>>>

https://archive.org/details/Puppy_Linux_Saluki_Pets
からPython3-3.1.4-i486.petをダウンロードしてインストールしました。

私が、今回python3.2以上を使いたい理由は、pythonのtexttableというモジュールを使用したい為です。texttableを使う為にはcallable という組み込みの関数が必要で Python 3.0 で一旦削除され、3.2から復活したようです。

よくわからないのですが、教えていただいたパッケージをインストールすれば、ターミナルから起動されるpythonが3.4に変わるだけで他に影響はないような気がするのですが、楽観的な考えでしょうか?

それと予め save file のバックアップを取っておくというのはどのようにすればよいのでしょうか?
save file自体なんなのか分かっていません。
初歩的な質問で申し訳ありません。
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

Re: python3.2 以降を使いたい

投稿記事by thinkpadnerd » 17/12/13(水) 09:17

”angel さんが書きました
> 教えていただいたパッケージをインストールすれば、ターミナルから起動されるpythonが3.4に変わるだけで他に影響はないような気がするのですが、楽観的な考えでしょうか?

python と打ち込めば、python 2.7.6 が呼び出され、python3.4 と打ち込めば、python 3.4.3 が呼び出されます。(そういう使い方でよろしければ)
これなら、問題は生じなさそうです。python 3.4.3 を使う時にちょっと煩わしいですが。

> それと予め save file のバックアップを取っておくというのはどのようにすればよいのでしょうか?

save file は個人保存ファイルのことです。シンプル版をお使いならば、「ヘルプ」の「Tahr アップデート」という項目を見てください。簡単にバックアップを取る方法を解説しています。
ThinkPad T42 (Puppy 412 / Lupu 528)
CPU Pentium M 1.6GHz, RAM 512MB
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606 / Xenial 7.5)
CPU AMD C-50 1.0GHz, RAM 4GB
thinkpadnerd
 
記事: 559
登録日時: 15/10/25(日) 14:00

Re: python3.2 以降を使いたい

投稿記事by angel » 17/12/14(木) 23:19

また今回も、的確なアドバイスをいただき、ありがとうございます。
感謝です。
おっしゃるように,プロンプトからpython3.4と入力して使う予定です。
ちなみに、自宅のLubuntuでも、python3.5と打って使っています。
職場のWindows機の方は、デフォルトで3.5になっています。
現在製作中のアプリがいろんな環境で、同様に動作するのを確認するのがそもそもの目的です。
ただ、話はそれますが、2,7でも3.5でも同様に動作するものを作るのは難しく、3.2以降限定になりそうです。
save fileの保存の仕方も簡単なようですね。
まだ、検証していないのですが・・・サブ機(pupyy Linux)が、離れたところにありまして・・・・
検証後、報告させていただきます。
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

Re: python3.2 以降を使いたい

投稿記事by angel » 17/12/15(金) 19:06

アドバイスに従い、python3.4のインストールを行いましたが、どうやら既にインストールされているようです。
しかし、端末からpython3.4と打ってもnot found とかえってきます。
pythonと打てば、python3.1.4が起動します。
現在、どうやったら3.4が起動できるのか模索中です。
添付ファイル
capture30180.png
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

Re: python3.2 以降を使いたい

投稿記事by angel » 17/12/15(金) 22:42

追加情報ですが、ルートからfindコマンドで”python3.4"を探しても一件もヒットしません。
あたりまえですがpython2.7などはちゃんとヒットします。
ということはどうもちゃんとインストールされていないようです。
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

Re: python3.2 以降を使いたい

投稿記事by thinkpadnerd » 17/12/16(土) 10:05

Python3-3.1.4-i486.pet が入っているのなら、アンインストールしてください。

最低限、下記の3つは必要なようです。
libpython3.4_3.4.3
python3.4_3.4.3
python3.4-minimal_3.4.3

このうち、libpython3.4_3.4.3 は、確認してみたところ、最初から入っていました。しかし、これだけでは実行ファイルがないので起動しません。

あとの2つは、パッケージマネージャで出てこない場合があるようです。直接ダウンロードするには、
https://packages.ubuntu.com/trusty/python/python3.4
https://packages.ubuntu.com/trusty/i386 ... .4-minimal
ThinkPad T42 (Puppy 412 / Lupu 528)
CPU Pentium M 1.6GHz, RAM 512MB
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606 / Xenial 7.5)
CPU AMD C-50 1.0GHz, RAM 4GB
thinkpadnerd
 
記事: 559
登録日時: 15/10/25(日) 14:00

Re: python3.2 以降を使いたい

投稿記事by angel » 17/12/16(土) 12:44

情報ありがとうございます。

アドバイスに従い、3.1をアンインストールして
python3.4_3.4.3-1ubuntu1~14.04.6_i386.deb
python3.4-minimal_3.4.3-1ubuntu1~14.04.6_i386.deb

をインストールしたのですが以下のようにNo module named 'encodings'
というエラーが出ます。

sh-4.3# python3.4
Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ImportError: No module named 'encodings'
Aborted
sh-4.3# find / -name "python3.4"
/usr/bin/python3.4
/usr/share/binfmts/python3.4/usr/lib/python3.4
/initrd/pup_rw/usr/bin/python3.4
/initrd/pup_rw/usr/share/binfmts/python3.4
/initrd/pup_rw/usr/share/menu/python3.4
/initrd/pup_rw/usr/share/lintian/ovsh-4.3# python3.4
Could not find platform independent libraries <prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ImportError: No module named 'encodings'
Aborted
sh-4.3#

まだ、何かが足りないようなので、調べています。
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

Re: python3.2 以降を使いたい

投稿記事by thinkpadnerd » 17/12/16(土) 14:50

”angel さんが書きました
> まだ、何かが足りないようなので、調べています。

足りないというよりもむしろ、Python3-3.1.4-i486.pet をアンインストールしても、完全には元に戻らないでシステムに何らかの影響が残っていることが考えられます。

パッケージマネージャのデータベースを更新して、libpython3.4_3.4.3 をインストールし直してはどうでしょうか。(インストール済の印が付いていても、インストールを強行することはできます)

それでも直らないようなら、個人保存ファイルを破棄して、まっさらな状態から始める必要があるかもしれません。(必要なデータだけは、どこかに退避させておいてください)
ThinkPad T42 (Puppy 412 / Lupu 528)
CPU Pentium M 1.6GHz, RAM 512MB
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606 / Xenial 7.5)
CPU AMD C-50 1.0GHz, RAM 4GB
thinkpadnerd
 
記事: 559
登録日時: 15/10/25(日) 14:00

Re: python3.2 以降を使いたい

投稿記事by angel » 17/12/17(日) 00:17

thinkpadnerd さん 回答ありがとうございます。
再インストールを行っても、状況が変わらないので、思い切って、tahrpup 6.0.5 日本語化版シンプル (PAE)をインストールし直すことにしました。
大事なデータはバックアップしてあるので問題ありません。
ところが、再度インストールしようとするとLICK-1.2.0-win32.exeがISOファイルを認識してくれません。
CD-ROMブートがきかないので、最初のインストールもLICKを使いました。
今度は、Windows側に問題があるようなので、Windowsの再セットアップを考えています。
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

Re: python3.2 以降を使いたい

投稿記事by ルビー » 17/12/17(日) 00:46

angel さんが書きました:今度は、Windows側に問題があるようなので、Windowsの再セットアップを考えています。

Windowsの再セットアップは最後の手段にして、とりあえずパピーをRAMモードで起動して、実験してみてはどうでしょう。
Grub4Dos の起動メニューに、RAMモードは入ってませんか。
アバター
ルビー
 
記事: 625
登録日時: 14/11/24(月) 12:12

Re: python3.2 以降を使いたい

投稿記事by thinkpadnerd » 17/12/17(日) 02:10

"angel さんが書きました
> 思い切って、tahrpup 6.0.5 日本語化版シンプル (PAE)をインストールし直すことにしました。
> 大事なデータはバックアップしてあるので問題ありません。

PC 電源投入後、lick 起動メニューで "no save file" という項目を選べば、puppy が初期状態で起動します。通常のOSのようにインストールし直す必要はありません。
ThinkPad T42 (Puppy 412 / Lupu 528)
CPU Pentium M 1.6GHz, RAM 512MB
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606 / Xenial 7.5)
CPU AMD C-50 1.0GHz, RAM 4GB
thinkpadnerd
 
記事: 559
登録日時: 15/10/25(日) 14:00

Re: python3.2 以降を使いたい

投稿記事by angel » 17/12/17(日) 10:48

>PC 電源投入後、lick 起動メニューで "no save file" という項目を選べば、puppy が初期状態で起動します。通常のOSのようにインストールし>直す必要はありません。
電源を入れると、lick起動メニューがありません。多分、Windows側でuninstallを行ったからだと思います。
現状、PCには,pup-4.3.1が残っています。
もう少し確認すればよかったと後悔しています。
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

Re: python3.2 以降を使いたい

投稿記事by angel » 17/12/17(日) 11:10

ルビーさん 情報ありがとうございます。
>Windowsの再セットアップは最後の手段にして、とりあえずパピーをRAMモードで起動して、実験してみてはどうでしょう。
>Grub4Dos の起動メニューに、RAMモードは入ってませんか。
Gurb4DOSのメニューありました。
grub> のプロンプトが出てくるのですが後の操作が分かりません
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

次へ

Return to 初心者のヘルプ

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]