python3.2 以降を使いたい

パピーリナックスを初めて使う方

モデレータ: 暇人, YoN, nyu

Re: python3.2 以降を使いたい

投稿記事by ルビー » 17/12/17(日) 12:00

angel さんが書きました:電源を入れると、lick起動メニューがありません。多分、Windows側でuninstallを行ったからだと思います。

LICK をアンインストールしちゃったみたいですね(^^;。
LICK は使った事がないのですが、Grub4Dos とパピーのFrugalインストールのディレクトリが残ってれば、manu.lst を作成してパピーの起動は可能だと思います。
ちょっと未経験では大変かもですが、Python使いの方なら問題無しかな。

シノバーさんの manu.lst の説明が分かりやすいです。
http://shino.pos.to/linux/puppy_grub4dos.html

menu.lst はコピペでも何とかなるので、PC環境の情報があれば助け船が来るかもです。
Grub4Dos のコマンドラインから、起動コマンドの手入力も可能かもしれませんが、やった事ないし、もっと面倒だと思います。
CD起動が出来れば簡単なのですが。

ちょっと手遅れになりましたが、パピーは簡単にまっさらの初期状態から何度でも実験を繰り返せます。
他のOSに比べると、大きなアドバンテージだと思います。
アバター
ルビー
 
記事: 625
登録日時: 14/11/24(月) 12:12

Re: python3.2 以降を使いたい

投稿記事by thinkpadnerd » 17/12/17(日) 14:32

”angel さんが書きました
> 電源を入れると、lick起動メニューがありません。多分、Windows側でuninstallを行ったからだと思います。

lick を通じて tahrpup をアンインストールし、lick もアンインストールしたということでしょうか。
それならば、もう一度 lick をインストールして、lick を通じて tahrpup を入れたらよさそうに思えますが。

> 現状、PCには,pup-4.3.1が残っています。

431 は起動する状態なのでしょうか。

> grub> のプロンプトが出てくるのですが後の操作が分かりません

コマンドの説明
http://www10.plala.or.jp/palm84/grub4dos.html

ハードディスクに Puppy が残っているのなら、kernel と initrd を指定すれば起動すると思います。

lick boot loader = grub4dos なんですが、lick をアンインストールしたのなら、grub のプロンプトが出るというのはどういう状態なのか... 見当がつきません。
「まっさらな状態からやり直す」と言うと、普通は「再インストールする」ということになりますが、Puppy の場合は違います。説明足らずで誤解を招いたかもしれません。
ThinkPad T42 (Puppy 412 / Lupu 528)
CPU Pentium M 1.6GHz, RAM 512MB
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606 / Xenial 7.5)
CPU AMD C-50 1.0GHz, RAM 4GB
thinkpadnerd
 
記事: 557
登録日時: 15/10/25(日) 14:00

Re: python3.2 以降を使いたい

投稿記事by angel » 17/12/17(日) 16:10

thinkpadnerdさん ルビーさん ありがとうございます。

シノバーさんの manu.lst の説明が分かりやすいですね。おかげで再インストールでき正常に起動しました。
これで、ISOファイルさえあれば、インストールできます。現在、どういうわけかLICKがISOファイルを認識してくれないのです。

これから本題のpython3.4のインストールです。
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

Re: python3.2 以降を使いたい

投稿記事by angel » 17/12/17(日) 16:56

thinkpadnerd さん ルビーさん ありがとうございました。
無事python3.4を使えるようになりました。
ポイントは、python3.4関係をすべてアンインストールしてから、python3.4_3.4.3だけをインストールするというところにありました。
他の必要なパッケージは、付随してインストールされました。
本当にご協力ありがとうございました。
添付ファイル
capture12793.png
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

Re: python3.2 以降を使いたい

投稿記事by ルビー » 17/12/17(日) 17:21

angel さんが書きました:シノバーさんの manu.lst の説明が分かりやすいですね。おかげで再インストールでき正常に起動しました。

ちょっと状況が不明ですが、起動したのは 431JP でしょうか。
そのPCには、以前 431JP が入れてあったのかなと想像してます。
Tahrpup 6.0.5 が起動したのなら、LICKでインストールできないとはならないと思うので、menu.lst から 431JP が起動できたと仮定します。

この状態から、Tahrpup 6.0.5 を起動するには、

1. Tahrpup 6.0.5 のISOファイルから、必要なファイルをディレクトリにコピー
2. 431JP と同じ要領で、Tahrpup 6.0.5 を menu.lst に追記

これで Tahrpup 6.0.5 が Grub4Dos の起動メニューに現れて起動できるので、LICKでインストールは不要になります。
Tahrpup 6.0.5 の起動(Frugalインストール)に必要なファイルは、

initrd.gz
puppy_tahr_6.0.5.sfs
vmlinuz
zdrv_tahr_6.0.5.sfs

追記
よく分からないけど、スレタイの問題が解決した様なので、めでたしめでたしかな。 :D
せっかく書いたから、消さないでおきます。
アバター
ルビー
 
記事: 625
登録日時: 14/11/24(月) 12:12

Re: python3.2 以降を使いたい

投稿記事by angel » 17/12/17(日) 17:47

ルビーさん

Tahrpup 6.0.5 を起動しています。
menu.lstの過去分が日付きで、自動的にバックアップされていたので(LICKの機能でしょうか?)、そこからコピーペーストしただけです。あとは、ISOファイルの中身を、残っていたTahrpup 6.0.5 のフォルダーにコピーして、再起動でOKでした。
LICKでできればまったく問題なかったのですが、ISOファイルをドラッグ&ドロップしても受け付けてくれません。その原因については、現状不明です。
angel
 
記事: 20
登録日時: 17/07/17(月) 12:40

1つ前へ

Return to 初心者のヘルプ

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]