puppy linux 5.7.1 日本語版で音が出ません

パピーリナックスを初めて使う方

モデレータ: 暇人, YoN, nyu

Re: puppy linux 5.7.1 日本語版で音が出ません

投稿記事by angel » 17/07/21(金) 19:35

master (volume) や headphone はミキサーにでてます。

教えていただいたコマンドも全部正常終了しています。

ミキサー画面を添付します。
添付ファイル
capture25874.png
angel
 
記事: 8
登録日時: 17/07/17(月) 12:40

Re: puppy linux 5.7.1 日本語版で音が出ません

投稿記事by thinkpadnerd » 17/07/21(金) 20:23

"angel さんが書きました
> ミキサー画面を添付します。

Master M の左には Master があるのですね。headphone が2つあるのが気になります。
571JP では speaker は出ません。Tahrpup にはあります。ですが、そのことと、音が出るかどうかは関係ありません。

headphone のうちのどちらか、または両方を mute にした場合に何か変化はありますか。

マシンには、物理ボリューム(ダイヤルとか押しボタンの類)あるいは、音量を操作するキー(例えば、[Fn] + いずれかのキー)はありますか。あるとしたら、それらを操作することで何か変化はありますか。

あとは、tahrpup を使ってみるとか、571JP でトライを続けるなら、カーネルモジュールのオプションをひとつひとつ試してみるとか (モジュールをアンロードし、新たなオプションを付けて再び読み込む) ...
ThinkPad T42 (Puppy 412 / Lupu 528)
CPU Pentium M 1.6GHz, RAM 512MB
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606)
CPU AMD C-50 1.0GHz, RAM 4GB
thinkpadnerd
 
記事: 448
登録日時: 15/10/25(日) 14:00

Re: puppy linux 5.7.1 日本語版で音が出ません

投稿記事by angel » 17/07/21(金) 20:24

thinkpadnerdさん お世話をかけ申し訳ありません。

私は見方が分からないのですが、lspci の結果が以下です。

sh-4.1# lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] nee ATI Device 5a31 (rev 01)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RS480 PCI Bridge
00:04.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RS480 PCI Bridge
00:05.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RS480 PCI Bridge
00:06.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RS480 PCI Bridge
00:07.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RS480 PCI Bridge
00:13.0 USB controller: Advanced Micro Devices [AMD] nee ATI IXP SB400 USB Host Controller
00:13.1 USB controller: Advanced Micro Devices [AMD] nee ATI IXP SB400 USB Host Controller
00:13.2 USB controller: Advanced Micro Devices [AMD] nee ATI IXP SB400 USB2 Host Controller
00:14.0 SMBus: Advanced Micro Devices [AMD] nee ATI IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: Advanced Micro Devices [AMD] nee ATI IXP SB400 IDE Controller
00:14.3 ISA bridge: Advanced Micro Devices [AMD] nee ATI IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: Advanced Micro Devices [AMD] nee ATI IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: Advanced Micro Devices [AMD] nee ATI IXP SB400 AC'97 Audio Controller (rev 02)
00:14.6 Modem: Advanced Micro Devices [AMD] nee ATI IXP SB400 AC'97 Modem Controller (rev 02)
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS400 [Radeon Xpress 200M]
0c:04.0 Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Wireless Network Adapter (rev 01)
0c:0a.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b1)
0c:0a.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 06)
0c:0a.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 15)
0c:0a.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 06)
0c:0a.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 01)
0c:0b.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
sh-4.1#

教えていただいたコマンドは全部正常終了しています。

ミキサーの画面も添付します。

なお、このNECパソコンは、CDインストールできなくなっています。なので、EXEインストールのできる Precise-571JPなどしか選択肢がない状態なんです。

ubuntu関連の情報なども見ながら、あきらめず解決策を探していきます。
添付ファイル
capture25874.png
alsamixer画面
angel
 
記事: 8
登録日時: 17/07/17(月) 12:40

Re: puppy linux 5.7.1 日本語版で音が出ません

投稿記事by thinkpadnerd » 17/07/21(金) 20:34

Advanced Micro Devices [AMD] nee ATI IXP SB400 AC'97 Audio Controller
これがサウンドカードですね。

投稿が前後してしまったので、私の一つ前の投稿も見てください。

> EXEインストールのできる Precise-571JPなどしか選択肢がない状態なんです。
windows と共存ですね。メモリの搭載量から XP だと思いますが、windows はシャットダウンした状態ですか。ハイバーネーション(休止状態)だったりすると、Linux との共存でおかしくなることがあります。

追記
571JP が起動に使っているブートローダ grub4dos のメニューを編集すれば、他の puppy を追加することもできます。

手動での操作が難しければ、LICK という windows installer があります。よかったら使ってみてください。
viewtopic.php?f=25&t=3245

ただし、これも grub4dos を利用しているので、いったん 571JP をアンインストールしてください。トリプルブートも可能です。例. windows + 571JP + Tahrpup
ThinkPad T42 (Puppy 412 / Lupu 528)
CPU Pentium M 1.6GHz, RAM 512MB
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606)
CPU AMD C-50 1.0GHz, RAM 4GB
thinkpadnerd
 
記事: 448
登録日時: 15/10/25(日) 14:00

Re: puppy linux 5.7.1 日本語版で音が出ません

投稿記事by thinkpadnerd » 17/07/21(金) 22:44

もう一つだけ。
モジュール snd_atiixp_modem を読み込まなくしたらどうでしょう。

一つのデバイスが音源とモデムの働きをするのです。で、モデムのドライバが邪魔をしているのではないかと考えます。モデムは使いませんよね。
システム -> BootManager -> 「モジュールをブラックリストする」

snd_atiixp_modem をブラックリストに入れてみて下さい。新しい設定を有効にするために再起動します。

うまくいく保証はありませんが、難しい操作ではないし、あとで元に戻すこともできます。
Good luck!
ThinkPad T42 (Puppy 412 / Lupu 528)
CPU Pentium M 1.6GHz, RAM 512MB
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606)
CPU AMD C-50 1.0GHz, RAM 4GB
thinkpadnerd
 
記事: 448
登録日時: 15/10/25(日) 14:00

Re: puppy linux 5.7.1 日本語版で音が出ません

投稿記事by angel » 17/07/22(土) 01:11

tahrpup 6.0.5 日本語化版シンプル (PAE)にすると音が出ました!!やったことはexternal amp ミュートぐらいです。
thinkpadnerd さん
タロ兵衛さん
ミトじいさん
ルビーさん
今回、フォーラムに初めて質問させて頂いて、こんなに協力していただけるという事実に驚いています。
感謝、感激です。

pale moonを起動すると重いのですが。メモリー増設か、そのへんを調整していけば使っていけそうです。
Operaにするか思案中です。
LICKの存在を教えていただいたことも大きな収穫です。

みなさんありがとうございました。
angel
 
記事: 8
登録日時: 17/07/17(月) 12:40

Re: puppy linux 5.7.1 日本語版で音が出ません

投稿記事by thinkpadnerd » 17/07/22(土) 10:27

Congratulations!
新しいカーネルでは、改善されていたということかもしれません。

”angel さんが書きました
> pale moonを起動すると重いのですが。

初回起動時は物理メモリだけを使って起動するので、メモリ搭載量が少ないと重くなりますが、save file やスワップファイルを作れば、まずまずの動作をすると思います。
ThinkPad T42 (Puppy 412 / Lupu 528)
CPU Pentium M 1.6GHz, RAM 512MB
ThinkPad X121e (Precise 571 / Tahr 605 / Tahr64 606)
CPU AMD C-50 1.0GHz, RAM 4GB
thinkpadnerd
 
記事: 448
登録日時: 15/10/25(日) 14:00

Re: puppy linux 5.7.1 日本語版で音が出ません

投稿記事by angel » 17/07/22(土) 11:32

再起動すると、pale moonも快適にうごいています。

ありがとうございました。
angel
 
記事: 8
登録日時: 17/07/17(月) 12:40

Re: puppy linux 5.7.1 日本語版で音が出ません

投稿記事by タロ兵衛 » 17/07/22(土) 21:09

よかったですね
これからもpuppyをよろしくです
暫定メインマシン(本体2000円Junk+余剰部品)
AMD Athlon 64 Dual Core 4400+
tahrpup 6.0.5 シンプル (PAE)-5
Slacko64 Puppy - 6.3.0
アバター
タロ兵衛
 
記事: 343
登録日時: 08/07/08(火) 00:11
お住まい: よこはま

1つ前へ

Return to 初心者のヘルプ

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[2人]